aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-07-12 14:14:51 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-20 10:24:51 +0100
commit9979e35ffb0dfb20d8aaffa8e2ec5e33f27fc009 (patch)
tree03c4ce1b548ba75a075a5910422fcff81d6a8551
parent769ad8e114fda1fe112d3747408edbeb7b066a85 (diff)
downloadopenembedded-core-contrib-9979e35ffb0dfb20d8aaffa8e2ec5e33f27fc009.tar.gz
python-six: Add to oe-core
Recipes are moved from meta-openembedded/meta-python Changes compared to meta-python version: * Modified to not inherit pypi * Fix python-io dependency for python3 * Support native, nativesdk * Do not install .egg Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python-six.inc16
-rw-r--r--meta/recipes-devtools/python/python-six_1.10.0.bb4
-rw-r--r--meta/recipes-devtools/python/python3-six_1.10.0.bb4
3 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-six.inc b/meta/recipes-devtools/python/python-six.inc
new file mode 100644
index 0000000000..bd12fa94a1
--- /dev/null
+++ b/meta/recipes-devtools/python/python-six.inc
@@ -0,0 +1,16 @@
+SUMMARY = "Python 2 and 3 compatibility library"
+HOMEPAGE = "https://pypi.python.org/pypi/six/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6f00d4a50713fa859858dd9abaa35b21"
+
+SRC_URI = "https://files.pythonhosted.org/packages/source/s/six/six-${PV}.tar.gz"
+SRC_URI[md5sum] = "34eed507548117b2ab523ab14b2f8b55"
+SRC_URI[sha256sum] = "105f8d68616f8248e24bf0e9372ef04d3cc10104f1980f54d57b2ce73a5ad56a"
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/six/"
+UPSTREAM_CHECK_REGEX = "/six/(?P<pver>(\d+[\.\-_]*)+)"
+
+BBCLASSEXTEND = "native nativesdk"
+
+S = "${WORKDIR}/six-${PV}"
diff --git a/meta/recipes-devtools/python/python-six_1.10.0.bb b/meta/recipes-devtools/python/python-six_1.10.0.bb
new file mode 100644
index 0000000000..4350485f73
--- /dev/null
+++ b/meta/recipes-devtools/python/python-six_1.10.0.bb
@@ -0,0 +1,4 @@
+inherit setuptools
+require python-six.inc
+
+RDEPENDS_${PN} += "python-io"
diff --git a/meta/recipes-devtools/python/python3-six_1.10.0.bb b/meta/recipes-devtools/python/python3-six_1.10.0.bb
new file mode 100644
index 0000000000..38a47b77dd
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-six_1.10.0.bb
@@ -0,0 +1,4 @@
+inherit setuptools3
+require python-six.inc
+
+RDEPENDS_${PN} += "python3-io"