aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-03-30 08:24:59 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-30 21:23:55 +0100
commitb4c2a90a2c6d224c041f44b6104b1dd9678d7c62 (patch)
tree39b94b8b11f588a9f849a2637cd3c7d6c00f571b
parent0a42e49bdcbc2f1f63b9d3fda9d4bc0f87a8eb01 (diff)
downloadopenembedded-core-contrib-b4c2a90a2c6d224c041f44b6104b1dd9678d7c62.tar.gz
linux-yocto/4.1: SMBus/iTCO backports
Backporting the following mainline commits to add Intel Broxton and Denverton support: 49b34899e7ca i2c: i801: Add support for Intel Broxton 69f6eeceb5b1 i2c: i801: Add support for Intel DNV b131e3e13838 watchdog: iTCO_wdt: Add support for TCO on Intel Sunrisepoint fce230a538de mfd: watchdog: iTCO_wdt: Expose watchdog properties using platform data a1a2140e856d intel_pmc_ipc: Update kerneldoc formatting e407caf0a583 intel_pmc_ipc: Fix compiler casting warnings 909588e549d7 intel_pmc_ipc: Add Intel Apollo Lake PMC IPC driver 1cd89340c1a9 mfd: lpc_ich: Assign subdevice ids automatically 729025b3e8d3 i2c: i801: Create iTCO device on newer Intel PCHs Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.1.bb16
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
index f217f78daf..0e25536538 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
@@ -2,7 +2,7 @@ KBRANCH ?= "standard/preempt-rt/base"
require recipes-kernel/linux/linux-yocto.inc
-SRCREV_machine ?= "8a1c72b29b63604b45ef13aed04f7bfe6d4fc277"
+SRCREV_machine ?= "d84b3cdc2d04fe42efb94b6f1e67c2d84af20bde"
SRCREV_meta ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
index 0af568509a..8300319e7e 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.1.18"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "e9b00f938e9971cf84dd33f317719c91135246e9"
+SRCREV_machine ?= "49b34899e7caa4237e6efbdf2e8f68e578707cee"
SRCREV_meta ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.1.bb b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
index caf71ae96a..e3f2e64450 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "e6b84f3f0c7292a7d3453e6bebd9987e08678a4b"
-SRCREV_machine_qemuarm64 ?= "e9b00f938e9971cf84dd33f317719c91135246e9"
-SRCREV_machine_qemumips ?= "c70a6ad907f0f9ffd4d911b6413e509766fba07b"
-SRCREV_machine_qemuppc ?= "e9b00f938e9971cf84dd33f317719c91135246e9"
-SRCREV_machine_qemux86 ?= "e9b00f938e9971cf84dd33f317719c91135246e9"
-SRCREV_machine_qemux86-64 ?= "e9b00f938e9971cf84dd33f317719c91135246e9"
-SRCREV_machine_qemumips64 ?= "a023db1f6f40280d3e254aed327f61f6d138992e"
-SRCREV_machine ?= "e9b00f938e9971cf84dd33f317719c91135246e9"
+SRCREV_machine_qemuarm ?= "55edd4698b9d54da4e648783918f2ee9ab7693ad"
+SRCREV_machine_qemuarm64 ?= "49b34899e7caa4237e6efbdf2e8f68e578707cee"
+SRCREV_machine_qemumips ?= "2c794fb0c6e6dec146e9d99018016da9bb04018d"
+SRCREV_machine_qemuppc ?= "49b34899e7caa4237e6efbdf2e8f68e578707cee"
+SRCREV_machine_qemux86 ?= "49b34899e7caa4237e6efbdf2e8f68e578707cee"
+SRCREV_machine_qemux86-64 ?= "49b34899e7caa4237e6efbdf2e8f68e578707cee"
+SRCREV_machine_qemumips64 ?= "28bf6a37b7600979593be2ee922361acd83d1617"
+SRCREV_machine ?= "49b34899e7caa4237e6efbdf2e8f68e578707cee"
SRCREV_meta ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \