aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-04-05 23:58:42 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-06 10:31:41 +0100
commitb99eec460cb14dce3580b8f5da6ce8b97d2078c5 (patch)
tree1fec15d4c9dfeac920d268eff14264069f9d9a8a
parented553f703703fa7743a2c9bd4496739a1f96ce2d (diff)
downloadopenembedded-core-contrib-b99eec460cb14dce3580b8f5da6ce8b97d2078c5.tar.gz
cmake: remove unused dont-run-cross-binaries.patch
It hasn't been used since June 2015 when upgraded the recipe, this patch was used for crosscompiling, now the crosscompile works well without it, so remove it. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch23
1 files changed, 0 insertions, 23 deletions
diff --git a/meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch b/meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch
deleted file mode 100644
index 0c059f12ed..0000000000
--- a/meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-cmake: don't run cross-binaries on host machine
-
-When doing the cross build we obviously cannot run those binaries on
-host since they can be binary incompatible.
-
-Upstream-Status: Inappropriate [embedded specific]
-
-Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-
-Index: cmake-2.8.10.1/CMakeLists.txt
-===================================================================
---- cmake-2.8.10.1.orig/CMakeLists.txt
-+++ cmake-2.8.10.1/CMakeLists.txt
-@@ -588,7 +588,8 @@ mark_as_advanced(CMAKE_STRICT)
-
- # build the remaining subdirectories
- add_subdirectory(Source)
--add_subdirectory(Utilities)
-+# Come on! Running the cross-binaries on host is not a good idea.
-+#add_subdirectory(Utilities)
- add_subdirectory(Tests)
-
- if(BUILD_TESTING)