aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-05 22:26:00 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-06 10:30:16 +0100
commit1ae11a6ea5ff82f6492a880ff45e19f3779918da (patch)
treefbb444cc04ea7153781260536106ffe8a993c231
parentb5304ce438666a7418746f4ddd32703ae3188089 (diff)
downloadopenembedded-core-contrib-1ae11a6ea5ff82f6492a880ff45e19f3779918da.tar.gz
bzip2: set correct soname
The correct name for the bzip2 shared library is libbz2.so.1.0.6, not libbz2.so.0.0.0. Pass -version-info to libtool to correct this. Also fix the configure.ac so that is doesn't mention libXrender and has the right version. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am1
-rw-r--r--meta/recipes-extended/bzip2/bzip2-1.0.6/configure.ac5
2 files changed, 2 insertions, 4 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am b/meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am
index 1d163b6c98..05d389fc7d 100644
--- a/meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am
+++ b/meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am
@@ -1,5 +1,6 @@
lib_LTLIBRARIES = libbz2.la
+libbz2_la_LDFLAGS = -version-info 1:6:0
libbz2_la_SOURCES = blocksort.c \
huffman.c \
diff --git a/meta/recipes-extended/bzip2/bzip2-1.0.6/configure.ac b/meta/recipes-extended/bzip2/bzip2-1.0.6/configure.ac
index 47ee576a8e..e2bf1bf110 100644
--- a/meta/recipes-extended/bzip2/bzip2-1.0.6/configure.ac
+++ b/meta/recipes-extended/bzip2/bzip2-1.0.6/configure.ac
@@ -1,12 +1,9 @@
AC_PREREQ([2.57])
-AC_INIT(bzip2, 2.0.5, , libXrender)
+AC_INIT(bzip2, 1.0.6)
AM_INIT_AUTOMAKE(foreign)
AM_MAINTAINER_MODE
-#AM_CONFIG_HEADER(config.h)
-
-# Check for progs
AC_PROG_CC
AC_PROG_LIBTOOL