aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-08-10 20:32:57 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-11 08:50:53 -0700
commitab9d3c4e2bfb68d3a67a85d5a8e799216103978a (patch)
tree4a6e2ffbfd1919b942fbb3f5efc29aeee356507c
parent274a1cb1bbeea01647a44e50e3323038da3e9647 (diff)
downloadopenembedded-core-contrib-ab9d3c4e2bfb68d3a67a85d5a8e799216103978a.tar.gz
weston: improve parallel make race fixes
The original fix is upstream already so mark as a backport, and update the patch with another race fix. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/wayland/weston/parallelmake.patch38
1 files changed, 28 insertions, 10 deletions
diff --git a/meta/recipes-graphics/wayland/weston/parallelmake.patch b/meta/recipes-graphics/wayland/weston/parallelmake.patch
index 34d7512b9e..42b5efbc3a 100644
--- a/meta/recipes-graphics/wayland/weston/parallelmake.patch
+++ b/meta/recipes-graphics/wayland/weston/parallelmake.patch
@@ -1,15 +1,33 @@
-The current approach used by the Makefile ends up installing
-weston.desktop twice and can give build failures when using
-parallel make flags. Change to just have one DATA reference.
+Backport two patches from upstream to fix parallel builds
-RP
-2015/8/3
-Upstream-Status: Pending
+- mkdir races (2eff22b8e6f6e5255a1915c33dfd91cecf02cbbc)
+- weston.desktop race (315476fa7b1f1c44c1b35116036df54ac5cb9a03)
-Index: weston-1.8.0/Makefile.am
-===================================================================
---- weston-1.8.0.orig/Makefile.am
-+++ weston-1.8.0/Makefile.am
+Upstream-Status: Backport
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/Makefile.am b/Makefile.am
+index 5819b19..ff13b19 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -20,7 +20,7 @@ weston.ini : $(srcdir)/weston.ini.in
+ $< > $@
+
+ ivi-shell/weston.ini : $(srcdir)/ivi-shell/weston.ini.in
+- $(AM_V_GEN)$(SED) \
++ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(SED) \
+ -e 's|@bindir[@]|$(bindir)|g' \
+ -e 's|@abs_top_builddir[@]|$(abs_top_builddir)|g' \
+ -e 's|@abs_top_srcdir[@]|$(abs_top_srcdir)|g' \
+@@ -29,7 +29,7 @@ ivi-shell/weston.ini : $(srcdir)/ivi-shell/weston.ini.in
+ $< > $@
+
+ tests/weston-ivi.ini : $(srcdir)/ivi-shell/weston.ini.in
+- $(AM_V_GEN)$(SED) \
++ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(SED) \
+ -e 's|@bindir[@]|$(bindir)|g' \
+ -e 's|@abs_top_builddir[@]|$(abs_top_builddir)|g' \
+ -e 's|@abs_top_srcdir[@]|$(abs_top_srcdir)|g' \
@@ -179,8 +179,7 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = src/weston.pc