aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2019-01-18 16:41:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-20 22:24:20 +0000
commitfdd0b9e26ef11fa287692848ea3add64ba623433 (patch)
tree7a25f8d15f8525491d687c448b61a4f83ecc3cb8
parentf9290f37b6dcaa18b09929ca3c18a4c8d0876364 (diff)
downloadopenembedded-core-contrib-fdd0b9e26ef11fa287692848ea3add64ba623433.tar.gz
base-files: Avoid problems if DISTRO_VERSION contains undefined variable
If DISTRO_VERSION is defined to some undefined variable, e.g., DISTRO_VERSION = "${FOO_VERSION}", and /bin/sh is dash, then do_install() would fail with an error such as: run.do_install.2945:193: run.do_install.2945: Syntax error: Unterminated quoted string This was due to unexpanded Python code making it into the shell code, confusing the shell parser. Reported-by: srinivasan <srinivasan.rns@gmail.com> Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/base-files/base-files_3.0.14.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/base-files/base-files_3.0.14.bb b/meta/recipes-core/base-files/base-files_3.0.14.bb
index 6e30c149ba..f42a4ef7c4 100644
--- a/meta/recipes-core/base-files/base-files_3.0.14.bb
+++ b/meta/recipes-core/base-files/base-files_3.0.14.bb
@@ -150,7 +150,7 @@ do_install_basefilesissue () {
printf "${DISTRO_NAME} " >> ${D}${sysconfdir}/issue
printf "${DISTRO_NAME} " >> ${D}${sysconfdir}/issue.net
if [ -n "${DISTRO_VERSION}" ]; then
- distro_version_nodate=${@'${DISTRO_VERSION}'.replace('snapshot-${DATE}','snapshot').replace('${DATE}','')}
+ distro_version_nodate="${@d.getVar('DISTRO_VERSION').replace('snapshot-${DATE}','snapshot').replace('${DATE}','')}"
printf "%s " $distro_version_nodate >> ${D}${sysconfdir}/issue
printf "%s " $distro_version_nodate >> ${D}${sysconfdir}/issue.net
fi