summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-15 15:11:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-16 22:39:17 +0000
commit95686432ecb7e411155563643d59a3d5f683937c (patch)
treef4542c07b979d6552cf953eb0a1a2ac306d1e8e3
parent90798e892fd3e0d2ef77a7ba64a33ea9f8ef317b (diff)
downloadopenembedded-core-contrib-95686432ecb7e411155563643d59a3d5f683937c.tar.gz
vulkan-samples: Disable PCH for reproducibility
We're still seeing reproducibility issues on the autobuilder with this recipe. I was able to make the output "match" by rebuilding the PCH and then rebuilding the binary objects, proving the PCH isn't deterministic. Disable PCH until we can get to the bottom of why that may be. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-samples_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-graphics/vulkan/vulkan-samples_git.bb b/meta/recipes-graphics/vulkan/vulkan-samples_git.bb
index 447d498fb3..a61dddeb3b 100644
--- a/meta/recipes-graphics/vulkan/vulkan-samples_git.bb
+++ b/meta/recipes-graphics/vulkan/vulkan-samples_git.bb
@@ -26,4 +26,8 @@ FILES_${PN} += "${datadir}"
# used for logging with LOGE in the code. We need to make this match the value we use
# in the debug source remapping from CFLAGS
#
-EXTRA_OECMAKE = "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/" \ No newline at end of file
+EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/"
+# Binaries built with PCH enabled don't appear reproducible, differing results were seen
+# from some builds depending on the point the PCH was compiled. Disable it to be
+# deterministic
+EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON"