summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-01-21 12:15:19 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-21 12:23:17 +0000
commit0ba3bde80ec7f2e66b6de790d8e198edef2b8980 (patch)
treea2d143e74ce02d25e0371b47bfe34c1a9ddab9ff
parent50d62a99341d06b8cc0efa1da25cd271e3b6ea9b (diff)
downloadopenembedded-core-contrib-0ba3bde80ec7f2e66b6de790d8e198edef2b8980.tar.gz
perl: fix a race issue during 'make install'
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl-sanity/files/0001-Make-sure-install.perl-runs-before-install.man.patch27
-rw-r--r--meta/recipes-devtools/perl-sanity/perl_5.28.1.bb1
2 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl-sanity/files/0001-Make-sure-install.perl-runs-before-install.man.patch b/meta/recipes-devtools/perl-sanity/files/0001-Make-sure-install.perl-runs-before-install.man.patch
new file mode 100644
index 0000000000..26590f5908
--- /dev/null
+++ b/meta/recipes-devtools/perl-sanity/files/0001-Make-sure-install.perl-runs-before-install.man.patch
@@ -0,0 +1,27 @@
+From 965adc80636e24e9608ca983c18c95cae08de021 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Mon, 21 Jan 2019 12:09:13 +0100
+Subject: [PATCH] Make sure install.perl runs before install.man
+
+Otherwise, install.man may attempt to write to non-existing directory:
+| Can't open file /home/pokybuild/yocto-worker/qemux86-64-x32/build/build/tmp/work/x86_64_x32-poky-linux-gnux32/perl/5.28.1-r0/image/usr/libx32/perl5/5.28.1/x86_64-linux/.packlist: No such file or directory at installman line 183.
+
+Upstream-Status: Submitted [https://github.com/arsv/perl-cross/issues/72]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index cd8d75f..82bdc1d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -410,7 +410,7 @@ install.perl: installperl | miniperl$X
+ ./miniperl_top installperl --destdir=$(DESTDIR) $(INSTALLFLAGS) $(STRIPFLAGS)
+ -@test ! -s extras.lst || $(MAKE) extras.install
+
+-install.man: installman pod/perltoc.pod | miniperl$X
++install.man: install.perl installman pod/perltoc.pod | miniperl$X
+ ./miniperl_top installman --destdir=$(DESTDIR) $(INSTALLFLAGS)
+
+ ifneq ($(perlname),perl)
diff --git a/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb b/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
index 71892a2436..949758c4d4 100644
--- a/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
+++ b/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
@@ -22,6 +22,7 @@ SRC_URI = "https://www.cpan.org/src/5.0/perl-${PV}.tar.gz;name=perl \
file://fix-race-failures.patch \
file://fix-race-failures-2.patch \
file://0001-Also-build-dynaloader-separately-as-race-failures-ha.patch \
+ file://0001-Make-sure-install.perl-runs-before-install.man.patch \
"
SRC_URI[perl.md5sum] = "838198c43d4f39d7af797e2f59c2bee5"