aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorReinette Chatre <reinette.chatre@intel.com>2015-08-20 14:34:33 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-24 23:45:22 +0100
commit9f625c2e6cc5c42d047ad33d5354522c18f2d6b7 (patch)
tree525f8a8223b297a221128388f6d233acc52c976c
parent5ed1c7f556df3fafd45d493010cc0bbe74d05ebd (diff)
downloadopenembedded-core-contrib-9f625c2e6cc5c42d047ad33d5354522c18f2d6b7.tar.gz
xf86-video-intel: enable xvmc feature by default and fix dependency
XvMC extends the X Video extension (Xv) and enables hardware rendered motion compensation support. In a test build enabling this feature increased the size of the xf86-video-intel package from 1386841 to 1847154 bytes. When we enable the xvmc feature in xf86-video-intel we see the following QA issue reported: QA Issue: xf86-video-intel rdepends on xcb-util, but it isn't a build dependency? We fix this by ensuring the build dependencies are set correctly when the xvmc feature is enabled. Signed-off-by: Reinette Chatre <reinette.chatre@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/xorg-driver/xf86-video-intel_2.99.917.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.99.917.bb b/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.99.917.bb
index 0ab7380506..5a3e06ccbd 100644
--- a/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.99.917.bb
+++ b/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.99.917.bb
@@ -19,7 +19,7 @@ SRC_URI[sha256sum] = "00b781eea055582820a123c47b62411bdf6aabf4f03dc0568faec55faf
DEPENDS += "virtual/libx11 drm libpciaccess pixman"
-PACKAGECONFIG ??= "sna udev ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'dri dri1 dri2', '', d)}"
+PACKAGECONFIG ??= "xvmc sna udev ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'dri dri1 dri2', '', d)}"
PACKAGECONFIG[dri] = "--enable-dri,--disable-dri"
PACKAGECONFIG[dri1] = "--enable-dri1,--disable-dri1,xf86driproto"
@@ -28,7 +28,7 @@ PACKAGECONFIG[dri3] = "--enable-dri3,--disable-dri3,dri3proto"
PACKAGECONFIG[sna] = "--enable-sna,--disable-sna"
PACKAGECONFIG[uxa] = "--enable-uxa,--disable-uxa"
PACKAGECONFIG[udev] = "--enable-udev,--disable-udev,udev"
-PACKAGECONFIG[xvmc] = "--enable-xvmc,--disable-xvmc,libxvmc"
+PACKAGECONFIG[xvmc] = "--enable-xvmc,--disable-xvmc,libxvmc xcb-util"
PACKAGECONFIG[tools] = "--enable-tools,--disable-tools,libxinerama libxrandr libxdamage libxfixes libxcursor libxtst libxext libxrender"
# --enable-kms-only option is required by ROOTLESS_X