aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2015-06-30 15:48:02 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-07 23:57:12 +0100
commit8df57b4b1a110dcbaab9652795fe5c0d86019554 (patch)
tree220512e879f06cb8e5bba8f3aacec8080634fb6e
parent6a5cc63e2d054f5e328e8c535a3dd11dab876c41 (diff)
downloadopenembedded-core-contrib-8df57b4b1a110dcbaab9652795fe5c0d86019554.tar.gz
core-image-kernel-dev: Define a correct subset of TEST_SUITES to run for this image
Since this image can be built with both poky and poky-lsb, ensure the correct tests are run in both cases, the auto detection does not quite work right in the poky-lsb case since not all the Posix cmdline utilites are added. Add connman and connman test for network sanity Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-extended/images/core-image-kernel-dev.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-extended/images/core-image-kernel-dev.bb b/meta/recipes-extended/images/core-image-kernel-dev.bb
index e1aa71a79f..6b636ed080 100644
--- a/meta/recipes-extended/images/core-image-kernel-dev.bb
+++ b/meta/recipes-extended/images/core-image-kernel-dev.bb
@@ -4,7 +4,7 @@ sensitive to kernel updates and version changes"
# Could also be core-image-basic, but we'll keep this small for now
require recipes-core/images/core-image-minimal.bb
-KERNEL_DEV_UTILS ?= "dropbear"
+KERNEL_DEV_UTILS ?= "dropbear connman"
KERNEL_DEV_TOOLS ?= "packagegroup-core-tools-profile packagegroup-core-buildessential kernel-devsrc"
KERNEL_DEV_MODULE ?= "kernel-modules"
@@ -15,3 +15,6 @@ CORE_IMAGE_EXTRA_INSTALL += "${KERNEL_DEV_MODULE} \
# We need extra space for things like kernel builds, etc.
IMAGE_ROOTFS_EXTRA_SPACE_append += "+ 3000000"
+
+# Let's define our own subset to test, we can later add a on-target kernel build even!
+DEFAULT_TEST_SUITES = "ping ssh df connman syslog scp date dmesg parselogs"