summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam A. Kennington III via Openembedded-core <openembedded-core@lists.openembedded.org>2019-04-02 14:53:47 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-03 14:46:57 +0100
commit6eadd9f5ac2887311ae9ed133b389ae4d64a8181 (patch)
tree81701a61021c49beb08c78d4b59298c98bff0ebf
parent1756f2354745ee709886683422887efed4e10dba (diff)
downloadopenembedded-core-contrib-6eadd9f5ac2887311ae9ed133b389ae4d64a8181.tar.gz
perl: Don't use TARGET_ARCH in filepaths
Platforms like powerpc64le have different variants of the same target. Perl guesses that the target should be called powerpc64le-linux, while TARGET_ARCH think it is called ppc64le-linux. If we use TARGET_ARCH for perl-native on powerpc64le this build will fail since the post-install rm command won't reference and existing file. We know that there is only one arch existing per build, so use a wildcard for finding the path instead of trying to guess the correct architecture name. Signed-off-by: William A. Kennington III <wak@google.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl-sanity/perl_5.28.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb b/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
index 5aa7cd3ee1..f3948a5f8d 100644
--- a/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
+++ b/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
@@ -107,8 +107,8 @@ do_install() {
install lib/ExtUtils/typemap ${D}${libdir}/perl5/${PV}/ExtUtils/
# Fix up shared library
- rm ${D}/${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/CORE/libperl.so
- ln -sf ../../../../libperl.so.${PERL_LIB_VER} ${D}/${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/CORE/libperl.so
+ rm ${D}/${libdir}/perl5/${PV}/*/CORE/libperl.so
+ ln -sf ../../../../libperl.so.${PERL_LIB_VER} $(echo ${D}/${libdir}/perl5/${PV}/*/CORE)/libperl.so
}
do_install_append_class-target() {