summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-10-08 12:02:21 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-10-08 20:47:52 +0100
commit2ed29a5d0d28bb96235c86f1e40f454edac65bf6 (patch)
treea7383e2cdb4584a99782d0e0f5bfece687242147
parent2795e3bfdefc9f48294802ea7301dae1910553dc (diff)
downloadopenembedded-core-contrib-2ed29a5d0d28bb96235c86f1e40f454edac65bf6.tar.gz
harfbuzz: add PACKAGECONFIGs for all the optional dependencies
Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz_2.6.1.bb23
1 files changed, 12 insertions, 11 deletions
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_2.6.1.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_2.6.1.bb
index b0f565b9b0..99cd4cd708 100644
--- a/meta/recipes-graphics/harfbuzz/harfbuzz_2.6.1.bb
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz_2.6.1.bb
@@ -7,29 +7,30 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=e11f5c3149cdec4bb309babb020b32b9 \
file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc"
-DEPENDS = "glib-2.0 cairo fontconfig freetype"
-
SRC_URI = "http://www.freedesktop.org/software/harfbuzz/release/${BP}.tar.xz"
SRC_URI[md5sum] = "89b758a2eb14d56a94406cf914b62388"
SRC_URI[sha256sum] = "c651fb3faaa338aeb280726837c2384064cdc17ef40539228d88a1260960844f"
inherit autotools pkgconfig lib_package gtk-doc
-PACKAGECONFIG ??= "icu"
-PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu"
+PACKAGECONFIG ??= "cairo fontconfig freetype glib icu"
+PACKAGECONFIG[cairo] = "--with-cairo,--without-cairo,cairo"
+PACKAGECONFIG[fontconfig] = "--with-fontconfig,--without-fontconfig,fontconfig"
+PACKAGECONFIG[freetype] = "--with-freetype,--without-freetype,freetype"
+PACKAGECONFIG[glib] = "--with-glib,--without-glib,glib-2.0"
PACKAGECONFIG[graphite] = "--with-graphite2,--without-graphite2,graphite2"
-
-EXTRA_OECONF = " \
- --with-cairo \
- --with-fontconfig \
- --with-freetype \
- --with-glib \
-"
+PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu"
PACKAGES =+ "${PN}-icu ${PN}-icu-dev"
LEAD_SONAME = "libharfbuzz.so"
+do_install_append() {
+ # If no tools are installed due to PACKAGECONFIG then this directory is
+ #still installed, so remove it to stop packaging wanings.
+ rmdir --ignore-fail-on-non-empty ${D}${bindir}
+}
+
FILES_${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"
FILES_${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \
${libdir}/libharfbuzz-icu.so \