aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-08 10:04:20 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-14 16:32:50 +0100
commite0ed7d74e61294a986f72a531b23f7e67922de29 (patch)
treeab41086e2aad7352690add837da66a9536d283d8
parentd1e02516dcce977a06320fcca968613466e43f29 (diff)
downloadopenembedded-core-contrib-e0ed7d74e61294a986f72a531b23f7e67922de29.tar.gz
libxcrypt: Provide virtual/crypt for target and native as well
virtual/crypt for musl will come from libc itself Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/conf/distro/include/tclibc-musl.inc1
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt_4.0.1.bb5
2 files changed, 1 insertions, 5 deletions
diff --git a/meta/conf/distro/include/tclibc-musl.inc b/meta/conf/distro/include/tclibc-musl.inc
index 052ae0e23b..8badbbb40a 100644
--- a/meta/conf/distro/include/tclibc-musl.inc
+++ b/meta/conf/distro/include/tclibc-musl.inc
@@ -9,6 +9,7 @@ LIBCOVERRIDE = ":libc-musl"
PREFERRED_PROVIDER_virtual/libc ?= "musl"
PREFERRED_PROVIDER_virtual/libiconv ?= "musl"
PREFERRED_PROVIDER_virtual/libintl ?= "musl"
+PREFERRED_PROVIDER_virtual/crypt ?= "musl"
PREFERRED_PROVIDER_virtual/nativesdk-libintl ?= "nativesdk-glibc"
PREFERRED_PROVIDER_virtual/nativesdk-libiconv ?= "nativesdk-glibc"
diff --git a/meta/recipes-core/libxcrypt/libxcrypt_4.0.1.bb b/meta/recipes-core/libxcrypt/libxcrypt_4.0.1.bb
index 6ed67a6761..f21029cdad 100644
--- a/meta/recipes-core/libxcrypt/libxcrypt_4.0.1.bb
+++ b/meta/recipes-core/libxcrypt/libxcrypt_4.0.1.bb
@@ -24,9 +24,4 @@ S = "${WORKDIR}/git"
BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE} -std=gnu99"
TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
-python () {
- if not bb.data.inherits_class('nativesdk', d):
- raise bb.parse.SkipRecipe("Recipe only applies in nativesdk case for now")
-}
-
BBCLASSEXTEND = "nativesdk"