summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2020-05-03 23:15:15 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-05 13:18:41 +0100
commit61d34df201cf6498854fa9258c320437b97071a4 (patch)
tree76e9944e77695b692f2a9ed56028cff82fee74bc
parent03c5cfd7611c88ce82d16619a49e3ea9fa7385d8 (diff)
downloadopenembedded-core-contrib-61d34df201cf6498854fa9258c320437b97071a4.tar.gz
libdnf: Use single-quotes around string literals used in SQL statements
If sqlite is built with -DSQLITE_DQS=0 in accordance with https://sqlite.org/quirks.html#dblquote, migration to version 1.2 of the history database would fail with: History database cannot be created: .../var/lib/dnf/history.sqlite. Error: SQLite error on ":memory:": Executing an SQL statement failed: no such column: 1.2 Signed-off-by: Peter Kjellerstedt <pkj@axis.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/libdnf/libdnf/0001-Use-single-quotes-around-string-literals-used-in-SQL.patch36
-rw-r--r--meta/recipes-devtools/libdnf/libdnf_0.47.0.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libdnf/libdnf/0001-Use-single-quotes-around-string-literals-used-in-SQL.patch b/meta/recipes-devtools/libdnf/libdnf/0001-Use-single-quotes-around-string-literals-used-in-SQL.patch
new file mode 100644
index 0000000000..6be484fea3
--- /dev/null
+++ b/meta/recipes-devtools/libdnf/libdnf/0001-Use-single-quotes-around-string-literals-used-in-SQL.patch
@@ -0,0 +1,36 @@
+From 96ca7d0049461df2293dd0000edcbc69b64255e0 Mon Sep 17 00:00:00 2001
+From: Peter Kjellerstedt <pkj@axis.com>
+Date: Sun, 3 May 2020 22:40:39 +0200
+Subject: [PATCH] Use single-quotes around string literals used in SQL
+ statements
+
+If sqlite is built with -DSQLITE_DQS=0 in accordance with
+https://sqlite.org/quirks.html#dblquote, migration to version 1.2 of the
+history database would fail with:
+
+ History database cannot be created: /var/lib/dnf/history.sqlite.
+ Error: SQLite error on ":memory:": Executing an SQL statement failed:
+ no such column: 1.2
+
+Upstream-Status: Submitted [https://github.com/rpm-software-management/libdnf/pull/951]
+Signed-off-by: Peter Kjellerstedt <pkj@axis.com>
+---
+ libdnf/transaction/sql/migrate_tables_1_2.sql | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/libdnf/transaction/sql/migrate_tables_1_2.sql b/libdnf/transaction/sql/migrate_tables_1_2.sql
+index 49b75315..f80ad1c4 100644
+--- a/libdnf/transaction/sql/migrate_tables_1_2.sql
++++ b/libdnf/transaction/sql/migrate_tables_1_2.sql
+@@ -1,9 +1,9 @@
+ R"**(
+ BEGIN TRANSACTION;
+ ALTER TABLE trans
+- ADD comment TEXT DEFAULT "";
++ ADD comment TEXT DEFAULT '';
+ UPDATE config
+- SET value = "1.2"
++ SET value = '1.2'
+ WHERE key = 'version';
+ COMMIT;
+ )**"
diff --git a/meta/recipes-devtools/libdnf/libdnf_0.47.0.bb b/meta/recipes-devtools/libdnf/libdnf_0.47.0.bb
index 1b4b7e4233..1b06d66b19 100644
--- a/meta/recipes-devtools/libdnf/libdnf_0.47.0.bb
+++ b/meta/recipes-devtools/libdnf/libdnf_0.47.0.bb
@@ -8,6 +8,7 @@ SRC_URI = "git://github.com/rpm-software-management/libdnf;branch=dnf-4-master \
file://0001-Get-parameters-for-both-libsolv-and-libsolvext-libdn.patch \
file://0001-Add-WITH_TESTS-option.patch \
file://0001-Look-fo-sphinx-only-if-documentation-is-actually-ena.patch \
+ file://0001-Use-single-quotes-around-string-literals-used-in-SQL.patch \
"
SRCREV = "8330eea6985c4e4b53796f858de5b6b38b1ddf5c"