summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-03-23 11:09:04 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-24 21:44:43 +0000
commit1aa2d2a5e91fddb80c792d6c2ff5fd2e80c751eb (patch)
tree6ae7d6ae2cdb9d2588f3009aeef43fb8af2b281f
parentd7888b6d7fd1a1930013f3d4e31a2522038cdc62 (diff)
downloadopenembedded-core-contrib-1aa2d2a5e91fddb80c792d6c2ff5fd2e80c751eb.tar.gz
perf: package python modules into perf-python
The scripts that are part of perf require python and supporting modules. The existing perf-pyton dependency only brought in core python, which left us unable to actually execute the scripts on target. With this additional runtime dependency, we can now execte the sample analysis scripts when perf-scripting is availble. This is a partial fix for [YOCTO #9069], since there are still scripts looking for non-existent modules, and those will be dealt with in future releases. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/perf/perf.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index e9c5c0c9f3..c43f39cd1d 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -201,7 +201,7 @@ PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python"
RDEPENDS_${PN} += "elfutils bash"
RDEPENDS_${PN}-archive =+ "bash"
-RDEPENDS_${PN}-python =+ "bash python"
+RDEPENDS_${PN}-python =+ "bash python python-modules"
RDEPENDS_${PN}-perl =+ "bash perl perl-modules"
RDEPENDS_${PN}-tests =+ "python"