summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2020-05-07 11:24:32 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-09 18:55:43 +0100
commit096a03659cdfa99ca2b4b50ff37d6f2001d0bc90 (patch)
tree90dba3fc8ac57a1bd6e11d072fed5b648fee5d7a
parent2873d4afac0845955e0811281203a39f4074b2c3 (diff)
downloadopenembedded-core-contrib-096a03659cdfa99ca2b4b50ff37d6f2001d0bc90.tar.gz
opkg-keyrings: check if opkg-key exists before run postinst
By default, the opkg-key command is not included in pokg package because it is only installed when gpg support is enabled. We'd better check if it exists before run 'opkg-key populate' in pkg_postinst. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb b/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
index a20e316a3d..07e2402545 100644
--- a/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
+++ b/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
@@ -36,5 +36,8 @@ FILES_${PN} = "${datadir}/opkg/keyrings"
RDEPENDS_${PN} = "opkg"
pkg_postinst_ontarget_${PN} () {
-opkg-key populate
+ if test -x ${bindir}/opkg-key
+ then
+ ${bindir}/opkg-key populate
+ fi
}