aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2017-02-09 00:56:20 -0800
committerRobert Yang <liezhi.yang@windriver.com>2017-02-20 02:21:12 +0000
commit0a3a087f8c908c934562f4ca8cc907db53edf128 (patch)
treeeeadb0e5fd743cfd075f1e8dfd1506070ef693eb
parentfa55ec72540126a55b195a99f56e1305b5a77c5d (diff)
downloadopenembedded-core-contrib-0a3a087f8c908c934562f4ca8cc907db53edf128.tar.gz
gawk/json-glib/libcheck: extend to nativesdk
They are required by nativesdk-cve-check-tool. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-extended/gawk/gawk_4.1.4.bb2
-rw-r--r--meta/recipes-gnome/json-glib/json-glib_1.2.2.bb2
-rw-r--r--meta/recipes-support/libcheck/libcheck_0.10.0.bb2
3 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-extended/gawk/gawk_4.1.4.bb b/meta/recipes-extended/gawk/gawk_4.1.4.bb
index b888df197c..dda38ef1bb 100644
--- a/meta/recipes-extended/gawk/gawk_4.1.4.bb
+++ b/meta/recipes-extended/gawk/gawk_4.1.4.bb
@@ -45,3 +45,5 @@ do_install_ptest() {
do cp ${S}/test/$i* ${D}${PTEST_PATH}/test; \
done
}
+
+BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-gnome/json-glib/json-glib_1.2.2.bb b/meta/recipes-gnome/json-glib/json-glib_1.2.2.bb
index 4e272be330..6869ba91c0 100644
--- a/meta/recipes-gnome/json-glib/json-glib_1.2.2.bb
+++ b/meta/recipes-gnome/json-glib/json-glib_1.2.2.bb
@@ -17,4 +17,4 @@ inherit gnomebase gettext lib_package gobject-introspection gtk-doc manpages
PACKAGECONFIG[manpages] = "--enable-man --with-xml-catalog=${STAGING_ETCDIR_NATIVE}/xml/catalog.xml, --disable-man, libxslt-native xmlto-native"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-support/libcheck/libcheck_0.10.0.bb b/meta/recipes-support/libcheck/libcheck_0.10.0.bb
index c0b459f661..9d34198a96 100644
--- a/meta/recipes-support/libcheck/libcheck_0.10.0.bb
+++ b/meta/recipes-support/libcheck/libcheck_0.10.0.bb
@@ -21,4 +21,4 @@ RREPLACES_${PN} = "check (<= 0.9.5)"
RDEPENDS_${PN} += "gawk"
RDEPENDS_${PN}_class-native = ""
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"