summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-06-13 08:28:48 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-14 22:47:43 +0100
commit144c6c7183dd2b32c65edf325038eb84683a28f8 (patch)
tree8c173e191dd6e2983297ea7b9c9d33b981902efb
parentb11ddab19bc7c0ce35b95345181de8a708268472 (diff)
downloadopenembedded-core-contrib-144c6c7183dd2b32c65edf325038eb84683a28f8.tar.gz
python3-scons: fix regex replacing python by python3
Match only the first line and match even if the line says python3. Otherwise we end up with multiple 3s at the end after multiple invocations of do_install on same source. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3-scons_3.0.5.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-scons_3.0.5.bb b/meta/recipes-devtools/python/python3-scons_3.0.5.bb
index 91e4a945e3..7fb75a627e 100644
--- a/meta/recipes-devtools/python/python3-scons_3.0.5.bb
+++ b/meta/recipes-devtools/python/python3-scons_3.0.5.bb
@@ -15,7 +15,7 @@ UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
inherit setuptools3
do_install_prepend() {
- sed -i -e "s:/usr/bin/env python:/usr/bin/env python3:g" ${S}/script/*
+ sed -i -e "1s,#!.*python.*,#!${USRBINPATH}/env python3," ${S}/script/*
}
RDEPENDS_${PN} = "\