summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2020-11-27 20:24:21 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-30 14:40:55 +0000
commit875c12f55ea34dbda6b11756d226ac09dfb282df (patch)
treef0a326262b345bba60ded733549f08c531b86b20
parent7990c78d14ad1862e4c9147f657c10e492cdf8b1 (diff)
downloadopenembedded-core-contrib-875c12f55ea34dbda6b11756d226ac09dfb282df.tar.gz
python3-setuptools-scm: move from meta-python
The blessed package to manage your versions by scm tags * Part of the dependency chain for pytest Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3-setuptools-scm_4.1.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools-scm_4.1.2.bb b/meta/recipes-devtools/python/python3-setuptools-scm_4.1.2.bb
new file mode 100644
index 0000000000..4ebbac6b65
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools-scm_4.1.2.bb
@@ -0,0 +1,21 @@
+SUMMARY = "the blessed package to manage your versions by scm tags"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
+
+SRC_URI[md5sum] = "e6c9fad17c90516d640868eb833d5150"
+SRC_URI[sha256sum] = "a8994582e716ec690f33fec70cca0f85bd23ec974e3f783233e4879090a7faa8"
+
+PYPI_PACKAGE = "setuptools_scm"
+inherit pypi setuptools3
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-debugger \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-py \
+ ${PYTHON_PN}-setuptools \
+"
+RDEPENDS_${PN}_class-native = "\
+ ${PYTHON_PN}-setuptools-native \
+"
+
+BBCLASSEXTEND = "native nativesdk"