summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2020-10-01 17:11:11 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-06 23:12:50 +0100
commit9d3cc0fb89cc4bd8a4f4fe168eff08a3c8bc8d2f (patch)
tree46028b7bf5f8a087602b0d687aacad4192a51539
parent7937da462b588403400755d264db0edde74aa4dc (diff)
downloadopenembedded-core-contrib-9d3cc0fb89cc4bd8a4f4fe168eff08a3c8bc8d2f.tar.gz
parted: improve ptest
Add a RRECOMMENDS on kernel-module-scsi-debug as this module is needed for many of the tests. Create the udev mount blacklist directory before writing into it, as it doesn't always exist. Delete any existing log files before calling make, as otherwise the tests cannot be repeated. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/parted/files/run-ptest2
-rw-r--r--meta/recipes-extended/parted/parted_3.3.bb2
2 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-extended/parted/files/run-ptest b/meta/recipes-extended/parted/files/run-ptest
index f39c478ce6..374f1bfbc9 100644
--- a/meta/recipes-extended/parted/files/run-ptest
+++ b/meta/recipes-extended/parted/files/run-ptest
@@ -1,5 +1,7 @@
#!/bin/sh
+mkdir -p /etc/udev/mount.blacklist.d
echo /dev/sda1 >> /etc/udev/mount.blacklist.d/parted-tmp
+rm -f *.log
make -C tests test-suite.log
rm /etc/udev/mount.blacklist.d/parted-tmp
diff --git a/meta/recipes-extended/parted/parted_3.3.bb b/meta/recipes-extended/parted/parted_3.3.bb
index aa4d8042cf..a1fd3ef07b 100644
--- a/meta/recipes-extended/parted/parted_3.3.bb
+++ b/meta/recipes-extended/parted/parted_3.3.bb
@@ -46,7 +46,7 @@ do_install_ptest() {
}
RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3 make gawk e2fsprogs-mke2fs"
-
+RRECOMMENDS_${PN}-ptest = "kernel-module-scsi-debug"
RDEPENDS_${PN}-ptest_append_libc-glibc = "\
glibc-utils \
locale-base-en-us \