summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-06-26 09:18:27 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-28 08:24:20 +0100
commitfec547397e9573855971880e7672cf4cb8af6da4 (patch)
tree8bd8fc82db7d9e19296abf808445c09c8a5edf13
parent2f981e31ad0386486706b52b08a5a2d42870ae35 (diff)
downloadopenembedded-core-contrib-fec547397e9573855971880e7672cf4cb8af6da4.tar.gz
stress-ng: upgrade 0.11.12 -> 0.11.14
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/stress-ng/stress-ng/no_daddr_t.patch16
-rw-r--r--meta/recipes-extended/stress-ng/stress-ng_0.11.14.bb (renamed from meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb)2
2 files changed, 14 insertions, 4 deletions
diff --git a/meta/recipes-extended/stress-ng/stress-ng/no_daddr_t.patch b/meta/recipes-extended/stress-ng/stress-ng/no_daddr_t.patch
index 877f4f0624..dba4494b91 100644
--- a/meta/recipes-extended/stress-ng/stress-ng/no_daddr_t.patch
+++ b/meta/recipes-extended/stress-ng/stress-ng/no_daddr_t.patch
@@ -1,4 +1,7 @@
-Define daddr_t if __DADDR_T_TYPE is not defined
+From 55e11765af2bdc8adfac87dab1fb2682f7e6c236 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 9 Jun 2020 22:10:28 -0700
+Subject: [PATCH] Define daddr_t if __DADDR_T_TYPE is not defined
glibc defined daddr_t but musl does not, ideally it should not be used
and simple int type is enough. However, its better to leave glibc behavior
@@ -7,9 +10,16 @@ as it is and only define it to int if daddr_t is not provided by libc
Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+---
+ stress-ng.h | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/stress-ng.h b/stress-ng.h
+index 1a66293..802dc25 100644
--- a/stress-ng.h
+++ b/stress-ng.h
-@@ -3750,6 +3750,10 @@ struct shim_statx {
+@@ -3763,6 +3763,10 @@ struct shim_statx {
uint64_t __spare2[14];
};
@@ -19,4 +29,4 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
/* old ustat struct */
struct shim_ustat {
- daddr_t f_tfree;
+ #if defined(HAVE_DADDR_T)
diff --git a/meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb b/meta/recipes-extended/stress-ng/stress-ng_0.11.14.bb
index c00086c095..f1d91da2b4 100644
--- a/meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb
+++ b/meta/recipes-extended/stress-ng/stress-ng_0.11.14.bb
@@ -9,7 +9,7 @@ SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \
file://no_daddr_t.patch \
"
-SRC_URI[sha256sum] = "0ccf437ca1876a3e8a55986c6481697045203a17f5994cb2f5096cd461d18031"
+SRC_URI[sha256sum] = "b21436fdbd9dc482a3fd95ae27cccf0097d0f226361ea3785215f7a4ad50136b"
DEPENDS = "coreutils-native"