summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-06-26 09:18:42 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-28 08:24:20 +0100
commite46f424748d9cc6d6160079e1a36fe43505ba2fa (patch)
treea2d813e914d7fbe99a17a31b000013fe42485ea8
parent2ee962186176c5ecb34c670e76415d4321affe76 (diff)
downloadopenembedded-core-contrib-e46f424748d9cc6d6160079e1a36fe43505ba2fa.tar.gz
go-binary-native: fix upstream version check
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/go/go-binary-native_1.14.4.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-binary-native_1.14.4.bb b/meta/recipes-devtools/go/go-binary-native_1.14.4.bb
index 3c535e14ce..72c988944f 100644
--- a/meta/recipes-devtools/go/go-binary-native_1.14.4.bb
+++ b/meta/recipes-devtools/go/go-binary-native_1.14.4.bb
@@ -11,6 +11,9 @@ SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz
SRC_URI[go_linux_amd64.sha256sum] = "aed845e4185a0b2a3c3d5e1d0a35491702c55889192bb9c30e67a3de6849c067"
SRC_URI[go_linux_arm64.sha256sum] = "05dc46ada4e23a1f58e72349f7c366aae2e9c7a7f1e7653095538bc5bba5e077"
+UPSTREAM_CHECK_URI = "https://golang.org/dl/"
+UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux"
+
S = "${WORKDIR}/go"
inherit goarch native