aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Gortmaker <paul.gortmaker@windriver.com>2017-03-16 10:20:53 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-17 11:55:24 +0000
commitba304046307cd741694b25215b562d5f05c9c7a5 (patch)
treeb87518cbc83a10f19ebd5cbd1b7e4af777abb346
parent19a825a578e2e705e5502982b787cff54d021359 (diff)
downloadopenembedded-core-contrib-ba304046307cd741694b25215b562d5f05c9c7a5.tar.gz
which: fix it so the manpage will respect alternatives
To fix: file /usr/share/man/man1/which.1 conflicts between attempted installs of debianutils-doc-4.8.1-r0.core2_64 and which-doc-2.21-r3.core2_64 Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/which/which_2.21.bb3
-rw-r--r--meta/recipes-support/debianutils/debianutils_4.8.1.bb3
2 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-extended/which/which_2.21.bb b/meta/recipes-extended/which/which_2.21.bb
index a7687f6fe4..fac0fd3944 100644
--- a/meta/recipes-extended/which/which_2.21.bb
+++ b/meta/recipes-extended/which/which_2.21.bb
@@ -30,3 +30,6 @@ do_configure_prepend() {
ALTERNATIVE_${PN} = "which"
ALTERNATIVE_PRIORITY = "100"
+
+ALTERNATIVE_${PN}-doc = "which.1"
+ALTERNATIVE_LINK_NAME[which.1] = "${mandir}/man1/which.1"
diff --git a/meta/recipes-support/debianutils/debianutils_4.8.1.bb b/meta/recipes-support/debianutils/debianutils_4.8.1.bb
index 54c74e097c..54c345ea25 100644
--- a/meta/recipes-support/debianutils/debianutils_4.8.1.bb
+++ b/meta/recipes-support/debianutils/debianutils_4.8.1.bb
@@ -40,6 +40,9 @@ ALTERNATIVE_PRIORITY="30"
ALTERNATIVE_${PN} = "add-shell installkernel remove-shell savelog tempfile which"
ALTERNATIVE_${PN}-run-parts = "run-parts"
+ALTERNATIVE_${PN}-doc = "which.1"
+ALTERNATIVE_LINK_NAME[which.1] = "${mandir}/man1/which.1"
+
ALTERNATIVE_LINK_NAME[add-shell]="${sbindir}/add-shell"
ALTERNATIVE_LINK_NAME[installkernel]="${sbindir}/installkernel"
ALTERNATIVE_LINK_NAME[remove-shell]="${sbindir}/remove-shell"