aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Goodbody <andrew.goodbody@cambrionix.com>2016-08-31 15:05:56 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-31 17:53:30 +0100
commitd55ded5f9ac6504ca0435d2614c381e80b9cbf12 (patch)
tree95b293de76db33e7116416dff14c88ddc961ef5f
parent2f910caec933dfc422aa76d5484e699c0af95788 (diff)
downloadopenembedded-core-contrib-d55ded5f9ac6504ca0435d2614c381e80b9cbf12.tar.gz
Fix out of tree builds of u-boot with gold linker
Need to reference config.mk file in source tree which is no longer the current directory when using out of tree builds. Signed-off-by: Andrew Goodbody <andrew.goodbody@cambrionix.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-bsp/u-boot/u-boot.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot.inc b/meta/recipes-bsp/u-boot/u-boot.inc
index 9e19c4f70f..915da8e744 100644
--- a/meta/recipes-bsp/u-boot/u-boot.inc
+++ b/meta/recipes-bsp/u-boot/u-boot.inc
@@ -67,7 +67,7 @@ UBOOT_ENV_SYMLINK ?= "${UBOOT_ENV}-${MACHINE}.${UBOOT_ENV_SUFFIX}"
do_compile () {
if [ "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
- sed -i 's/$(CROSS_COMPILE)ld$/$(CROSS_COMPILE)ld.bfd/g' config.mk
+ sed -i 's/$(CROSS_COMPILE)ld$/$(CROSS_COMPILE)ld.bfd/g' ${S}/config.mk
fi
unset LDFLAGS