aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Looijmans <mike.looijmans@topic.nl>2016-08-31 15:22:51 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-31 17:53:30 +0100
commita650a4245eafa63261494b01db2d70e26868fb66 (patch)
tree4337f26194bf0c55924c7c4b42ae540336f4ab01
parentd8233c9e0085e0aadaa45a79a3fbb8557e184e78 (diff)
downloadopenembedded-core-contrib-a650a4245eafa63261494b01db2d70e26868fb66.tar.gz
initscripts: Start devpts at 06 instead of 38
For example bootlogd needs devpts to be running, but bootlogd starts at 07. Starting bootlogd early makes perfect sense, so the best option here is to move devpts up to 06 to prevent this error message at boot: cannot allocate pseudo tty: No such file or directory Systems that have CONFIG_LEGACY_PTYS in the kernel will not see this message. Since it is called "LEGACY" for a reason, fixing this in userspace appears to be the better option here. The devpts script does not need anything except a mounted "/dev" which has been arranged in "S02sysfs.sh" already. Signed-off-by: Mike Looijmans <mike.looijmans@topic.nl> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/initscripts/initscripts_1.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/initscripts/initscripts_1.0.bb b/meta/recipes-core/initscripts/initscripts_1.0.bb
index 148491fb2c..8f110b0050 100644
--- a/meta/recipes-core/initscripts/initscripts_1.0.bb
+++ b/meta/recipes-core/initscripts/initscripts_1.0.bb
@@ -138,7 +138,7 @@ do_install () {
update-rc.d -r ${D} sysfs.sh start 02 S .
update-rc.d -r ${D} populate-volatile.sh start 37 S .
update-rc.d -r ${D} read-only-rootfs-hook.sh start 29 S .
- update-rc.d -r ${D} devpts.sh start 38 S .
+ update-rc.d -r ${D} devpts.sh start 06 S .
if [ "${TARGET_ARCH}" = "arm" ]; then
update-rc.d -r ${D} alignment.sh start 06 S .
fi