summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@windriver.com>2022-01-06 12:12:34 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-01-07 14:37:50 +0000
commitb9fd7cd319a1d8f0ddf5ea60710b015e9afb588c (patch)
treeee5fd455d18f50874d677c7c8620743a87209675
parent52d5f76f54eac384f9480dffe96df089d9ee8f33 (diff)
downloadopenembedded-core-contrib-b9fd7cd319a1d8f0ddf5ea60710b015e9afb588c.tar.gz
perl: Enable threading
When the tranisiton to perl-cross occured, the threading define seems to have been missed. The perl tests for threading where simply skipped, so there was no direct failures. This was verified by running perl ptest before and after the change to see PASS vs SKIP results of threaded related tests. NOTE: Perl officially discourges the use of threads, so this functionality maybe depercated in the future [0][1] v2: adds the usethreads to native and nativesdk. This was tested by builing postresql and rrdtool which use perl and automake. [0] https://perldoc.perl.org/5.34.0-RC2/threads#WARNING [1] https://perldoc.perl.org/perlpolicy#discouraged Signed-off-by: Saul Wold <saul.wold@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl/perl_5.34.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.34.0.bb b/meta/recipes-devtools/perl/perl_5.34.0.bb
index a6ae80f07e..e4bcfe3ce6 100644
--- a/meta/recipes-devtools/perl/perl_5.34.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.34.0.bb
@@ -53,6 +53,7 @@ do_configure:class-target() {
./configure --prefix=${prefix} --libdir=${libdir} \
--target=${TARGET_SYS} \
-Duseshrplib \
+ -Dusethreads \
-Dsoname=libperl.so.5 \
-Dvendorprefix=${prefix} \
-Darchlibexp=${STAGING_LIBDIR}/perl5/${PV}/${TARGET_ARCH}-linux \
@@ -80,6 +81,7 @@ do_configure:class-nativesdk() {
./configure --prefix=${prefix} \
--target=${TARGET_SYS} \
-Duseshrplib \
+ -Dusethreads \
-Dsoname=libperl.so.5 \
-Dvendorprefix=${prefix} \
-Darchlibexp=${STAGING_LIBDIR}/perl5/${PV}/${TARGET_ARCH}-linux \
@@ -94,6 +96,7 @@ do_configure:class-native() {
./configure --prefix=${prefix} \
-Dbin=${bindir}/perl-native \
-Duseshrplib \
+ -Dusethreads \
-Dsoname=libperl.so.5 \
-Dvendorprefix=${prefix} \
-Ui_xlocale \