summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-12-27 21:20:19 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-01-05 17:18:11 +0000
commit66e06fd409c27f212f41b69a01416cea41a198cd (patch)
treefbc2adb3e6f43471921b1a7c95ca69c9c408c9b9
parent98a87bcfa50fc46ea86a085d330f5cbc41ddaaa5 (diff)
downloadopenembedded-core-contrib-66e06fd409c27f212f41b69a01416cea41a198cd.tar.gz
gnupg: upgrade 2.3.3 -> 2.3.4
refresh relocate.patch Chanlog: ======== Bugs fixed for this release <https://dev.gnupg.org/#####> gpg: New option --min-rsa-length. [rG5f39db70c0] gpg: New option --forbid-gen-key. [rGc397ba3ac0] gpg: New option --override-compliance-check. [T5655] gpgconf: New command --show-configs. [rGa0fb78ee0f] agent,dirmngr,keyboxd: New option --steal-socket. [rGb0079ab39d,rGdd708f60d5] gpg: Fix printing of binary notations. [T5667] gpg: Remove stale ultimately trusted keys from the trustdb. [T5685,T5742] gpg: Fix indentation of --print-mds and --print-md sha512. [T5679] gpg: Emit gpg 2.2 compatible Ed25519 signature. [T5331] gpgsm: Detect circular chains in --list-chain. [rG74c5b35062] dirmngr: Make reading resolv.conf more robust. [T5657] dirmngr: Ask keyservers to provide the key fingerprints. [T5741] gpgconf: Allow changing gpg's deprecated keyserver option. [T5462] gpg-wks-server: Fix created file permissions. [rG60be00b033] scd: Support longer data for ssh-agent authentication with openpgp cards. [T5682] scd: Modify DEVINFO behavior to support looping forever. [T5359] Support gpgconf.ctl for NetBSD and Solaris. [T5656,T5671] Silence "Garbled console data" warning under Windows in most cases. [rGe293da3b21] Silence warning about the rootdir under Unices w/o a mounted /proc file system. [T5656] Fix possible build problems about missing include files. [T5592] Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/gnupg/gnupg/relocate.patch22
-rw-r--r--meta/recipes-support/gnupg/gnupg_2.3.4.bb (renamed from meta/recipes-support/gnupg/gnupg_2.3.3.bb)2
2 files changed, 11 insertions, 13 deletions
diff --git a/meta/recipes-support/gnupg/gnupg/relocate.patch b/meta/recipes-support/gnupg/gnupg/relocate.patch
index 53679bf1d9..74f48e9582 100644
--- a/meta/recipes-support/gnupg/gnupg/relocate.patch
+++ b/meta/recipes-support/gnupg/gnupg/relocate.patch
@@ -1,4 +1,4 @@
-From 766d37fe9acd9fdaaff9c094635e06b50c5902d7 Mon Sep 17 00:00:00 2001
+From 1e34e1d477f843c0ee2f1a3fddc20201f0233e81 Mon Sep 17 00:00:00 2001
From: Ross Burton <ross.burton@intel.com>
Date: Wed, 19 Sep 2018 14:44:40 +0100
Subject: [PATCH] Allow the environment to override where gnupg looks for its
@@ -8,15 +8,16 @@ Upstream-Status: Inappropriate [OE-specific]
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+
---
common/homedir.c | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/common/homedir.c b/common/homedir.c
-index 455c188..55049db 100644
+index 174d961..f4c25fb 100644
--- a/common/homedir.c
+++ b/common/homedir.c
-@@ -1155,7 +1155,7 @@ gnupg_socketdir (void)
+@@ -1161,7 +1161,7 @@ gnupg_socketdir (void)
if (!name)
{
unsigned int dummy;
@@ -25,7 +26,7 @@ index 455c188..55049db 100644
gpgrt_annotate_leaked_object (name);
}
-@@ -1187,7 +1187,7 @@ gnupg_sysconfdir (void)
+@@ -1193,7 +1193,7 @@ gnupg_sysconfdir (void)
if (dir)
return dir;
else
@@ -34,7 +35,7 @@ index 455c188..55049db 100644
#endif /*!HAVE_W32_SYSTEM*/
}
-@@ -1223,7 +1223,7 @@ gnupg_bindir (void)
+@@ -1229,7 +1229,7 @@ gnupg_bindir (void)
return name;
}
else
@@ -43,7 +44,7 @@ index 455c188..55049db 100644
#endif /*!HAVE_W32_SYSTEM*/
}
-@@ -1250,7 +1250,7 @@ gnupg_libexecdir (void)
+@@ -1256,7 +1256,7 @@ gnupg_libexecdir (void)
return name;
}
else
@@ -52,7 +53,7 @@ index 455c188..55049db 100644
#endif /*!HAVE_W32_SYSTEM*/
}
-@@ -1280,7 +1280,7 @@ gnupg_libdir (void)
+@@ -1286,7 +1286,7 @@ gnupg_libdir (void)
return name;
}
else
@@ -61,7 +62,7 @@ index 455c188..55049db 100644
#endif /*!HAVE_W32_SYSTEM*/
}
-@@ -1311,7 +1311,7 @@ gnupg_datadir (void)
+@@ -1317,7 +1317,7 @@ gnupg_datadir (void)
return name;
}
else
@@ -70,7 +71,7 @@ index 455c188..55049db 100644
#endif /*!HAVE_W32_SYSTEM*/
}
-@@ -1343,7 +1343,7 @@ gnupg_localedir (void)
+@@ -1349,7 +1349,7 @@ gnupg_localedir (void)
return name;
}
else
@@ -79,6 +80,3 @@ index 455c188..55049db 100644
#endif /*!HAVE_W32_SYSTEM*/
}
---
-2.20.1
-
diff --git a/meta/recipes-support/gnupg/gnupg_2.3.3.bb b/meta/recipes-support/gnupg/gnupg_2.3.4.bb
index 5614ac6473..7faaffbc27 100644
--- a/meta/recipes-support/gnupg/gnupg_2.3.3.bb
+++ b/meta/recipes-support/gnupg/gnupg_2.3.4.bb
@@ -24,7 +24,7 @@ SRC_URI:append:class-native = " file://0001-configure.ac-use-a-custom-value-for-
file://relocate.patch"
SRC_URI:append:class-nativesdk = " file://relocate.patch"
-SRC_URI[sha256sum] = "5789b86da6a1a6752efb38598f16a77af51170a8494039c3842b085032e8e937"
+SRC_URI[sha256sum] = "f3468ecafb1d7f9ad7b51fd1db7aebf17ceb89d2efa8a05cf2f39b4d405402ae"
EXTRA_OECONF = "--disable-ldap \
--disable-ccid-driver \