summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-01 16:50:25 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-06 23:13:58 +0100
commitef9c11797b5d626bdb40b4509d8b2b0d461ff9ea (patch)
tree66eb11d83b856b2ac834fd3da5a6fac0ecc164be
parentf18817f5340d06f7b4bb846a83b48731a1b9c4bc (diff)
downloadopenembedded-core-contrib-ef9c11797b5d626bdb40b4509d8b2b0d461ff9ea.tar.gz
libtools-cross/shadow-sysroot: Use nopackages inherit
When testing pseudo changes I realised these recipes have packaging tasks but don't generate packages. Drop the packages tasks for cleanliness. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/libtool/libtool-cross_2.4.6.bb2
-rw-r--r--meta/recipes-extended/shadow/shadow-sysroot_4.6.bb2
2 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-cross_2.4.6.bb b/meta/recipes-devtools/libtool/libtool-cross_2.4.6.bb
index 522bf3a0e9..02c6e152fc 100644
--- a/meta/recipes-devtools/libtool/libtool-cross_2.4.6.bb
+++ b/meta/recipes-devtools/libtool/libtool-cross_2.4.6.bb
@@ -6,6 +6,8 @@ SRC_URI += "file://fixinstall.patch"
datadir = "${STAGING_DIR_TARGET}${target_datadir}"
+inherit nopackages
+
do_configure_prepend () {
# Remove any existing libtool m4 since old stale versions would break
# any upgrade
diff --git a/meta/recipes-extended/shadow/shadow-sysroot_4.6.bb b/meta/recipes-extended/shadow/shadow-sysroot_4.6.bb
index a8c1539c92..1f6232e43c 100644
--- a/meta/recipes-extended/shadow/shadow-sysroot_4.6.bb
+++ b/meta/recipes-extended/shadow/shadow-sysroot_4.6.bb
@@ -27,3 +27,5 @@ SYSROOT_DIRS += "${sysconfdir}"
# otherwise: dbus-dev depends on shadow-sysroot-dev which depends on shadow-sysroot
# and this has another copy of /etc/login.defs already provided by shadow
PACKAGES = ""
+
+inherit nopackages