aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-05-23 14:19:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-25 07:49:54 +0100
commit72792a2fd900fe86d18bd8e330bc0535e2eeb80d (patch)
treef37afc93616efb811b1067d4797370bba728eb36
parent50d63fa346bbb05dafffc0cb55e21e1092272d95 (diff)
downloadopenembedded-core-contrib-72792a2fd900fe86d18bd8e330bc0535e2eeb80d.tar.gz
mkelfimage: fix compile issues
This fixes a couple issues introduced by the previous patch. There were a couple spots where HOST_CFLAGS needed changing to CFLAGS. This fixes builds with security_flags. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/mkelfimage/mkelfimage/cross-compile.patch4
-rw-r--r--meta/recipes-devtools/mkelfimage/mkelfimage_git.bb7
2 files changed, 7 insertions, 4 deletions
diff --git a/meta/recipes-devtools/mkelfimage/mkelfimage/cross-compile.patch b/meta/recipes-devtools/mkelfimage/mkelfimage/cross-compile.patch
index 2ae9fb50aa..a162eb7d15 100644
--- a/meta/recipes-devtools/mkelfimage/mkelfimage/cross-compile.patch
+++ b/meta/recipes-devtools/mkelfimage/mkelfimage/cross-compile.patch
@@ -67,7 +67,7 @@ index 51531d6..7e8aa3c 100644
$(LI386_OBJ)/mkelf-linux-i386.o: $(LI386_DIR)/mkelf-linux-i386.c $(LI386_DIR)/convert.bin.c $(LI386_DEP)
$(MKDIR) -p $(@D)
- $(HOST_CC) $(HOST_CFLAGS) -c -g $< -o $@
-+ $(CC) $(HOST_CFLAGS) -c -g $< -o $@
++ $(CC) $(CFLAGS) -c -g $< -o $@
ifdef I386_CC
@@ -80,7 +80,7 @@ index 38f5d8c..5df8870 100644
$(LIA64_OBJ)/mkelf-linux-ia64.o: $(LIA64_DIR)/mkelf-linux-ia64.c $(LIA64_DIR)/convert.bin.c $(LIA64_DEP)
$(MKDIR) -p $(@D)
- $(HOST_CC) $(HOST_CFLAGS) -c -g $< -o $@
-+ $(CC) $(HOST_CFLAGS) -c -g $< -o $@
++ $(CC) $(CFLAGS) -c -g $< -o $@
ifdef IA64_CC
diff --git a/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb b/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
index d7a4429fb8..2bcc8d7bd9 100644
--- a/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
+++ b/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
@@ -24,8 +24,11 @@ CLEANBROKEN = "1"
S = "${WORKDIR}/git/util/mkelfImage"
CFLAGS += "-fno-stack-protector"
-CACHED_CONFIGUREVARS += "HOST_CC='${BUILD_CC}'"
-EXTRA_OEMAKE += "HOST_CPPFLAGS='${BUILD_CPPFLAGS}'"
+CACHED_CONFIGUREVARS += "\
+ HOST_CC='${BUILD_CC}' \
+ HOST_CFLAGS='${BUILD_CFLAGS}' \
+ HOST_CPPFLAGS='${BUILD_CPPFLAGS}' \
+"
inherit autotools-brokensep