aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-27 21:52:12 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-31 14:25:44 +0100
commitfc3aef67a95a90e9a485c6b0e93db8cdeab5d3ab (patch)
tree5fd93f53c782f2438dfa521c6a04f8c63a633475
parentca61f5437cb2421a67f002785e644ba215e04aaf (diff)
downloadopenembedded-core-contrib-fc3aef67a95a90e9a485c6b0e93db8cdeab5d3ab.tar.gz
ninja: Add recipe
llvm is using it, therefore move it from meta-oe Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta/recipes-devtools/ninja/ninja_1.7.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ninja/ninja_1.7.2.bb b/meta/recipes-devtools/ninja/ninja_1.7.2.bb
new file mode 100644
index 0000000000..20dca2f0af
--- /dev/null
+++ b/meta/recipes-devtools/ninja/ninja_1.7.2.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Ninja is a small build system with a focus on speed."
+HOMEPAGE = "http://martine.github.com/ninja/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
+
+DEPENDS = "re2c-native ninja-native"
+
+SRCREV = "717b7b4a31db6027207588c0fb89c3ead384747b"
+
+SRC_URI = "git://github.com/martine/ninja.git;branch=release"
+
+S = "${WORKDIR}/git"
+
+do_configure[noexec] = "1"
+
+do_compile_class-native() {
+ ./configure.py --bootstrap
+}
+
+do_compile() {
+ ./configure.py
+ ninja
+}
+
+do_install() {
+ install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja
+}
+
+BBCLASSEXTEND = "native nativesdk"