aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-23 17:47:48 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-09 09:24:02 +0100
commitbb89849b5edb05a953586d190826a67ba87c1c5a (patch)
tree9a6c2f4a8e340af13df8d173c0365743309cc91a
parent7685bac83504e8de6c02d93e39e40f38e51994bb (diff)
downloadopenembedded-core-contrib-bb89849b5edb05a953586d190826a67ba87c1c5a.tar.gz
go: Remove -fPIE -pie from SECURITY_PIE_CFLAGS
External compilers will explicitly pass -fPIE -pie flags unlike internal toolchain which does not use them, so the build fails with external toolchains because, its passing these flags to linker when building with -r option and fails to link | /mnt/a/oe/build/tmp/work/corei7-64-bec-linux/go/1.8.3-r0/recipe-sysroot-native/usr/bin/x86_64-bec-linux/x86_64-bec-linux-ld: -r and -pie may not be used together Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/go/go_1.8.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go_1.8.bb b/meta/recipes-devtools/go/go_1.8.bb
index 091b1318af..ef8bc14383 100644
--- a/meta/recipes-devtools/go/go_1.8.bb
+++ b/meta/recipes-devtools/go/go_1.8.bb
@@ -1,3 +1,4 @@
require go-${PV}.inc
require go.inc
TUNE_CCARGS_remove = "-march=mips32r2"
+SECURITY_PIE_CFLAGS_remove = "-fPIE -pie"