aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-09 07:19:21 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-11 00:08:33 +0100
commita703bb6159dd69020fb40db7a6a0811f45869972 (patch)
tree6d3d51f752535b3c860c345c0be631f340ca07bc
parent624aed5d450664b0f0a36b14d658248202f864ed (diff)
downloadopenembedded-core-contrib-a703bb6159dd69020fb40db7a6a0811f45869972.tar.gz
python-numpy: Upgrade to 1.13.1
Update LICENSE to BSD-3-Clause as per https://github.com/numpy/numpy/blob/master/LICENSE.txt LIC_FILES_CHKSUM changed due to copyright year change see https://github.com/numpy/numpy/commit/b2ff4f13197dd58508d3d025a9034519974750bd Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python-numpy/files/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch24
-rw-r--r--meta/recipes-devtools/python-numpy/python-numpy_1.13.1.bb (renamed from meta/recipes-devtools/python-numpy/python-numpy_1.11.2.bb)15
-rw-r--r--meta/recipes-devtools/python-numpy/python3-numpy_1.13.1.bb (renamed from meta/recipes-devtools/python-numpy/python3-numpy_1.11.2.bb)14
3 files changed, 25 insertions, 28 deletions
diff --git a/meta/recipes-devtools/python-numpy/files/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch b/meta/recipes-devtools/python-numpy/files/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch
index 5b134edf07..ffd6ced136 100644
--- a/meta/recipes-devtools/python-numpy/files/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch
+++ b/meta/recipes-devtools/python-numpy/files/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch
@@ -11,11 +11,11 @@ Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
numpy/distutils/system_info.py | 50 +++++-------------------------------------
1 file changed, 6 insertions(+), 44 deletions(-)
-diff --git a/numpy/distutils/system_info.py b/numpy/distutils/system_info.py
-index 9dd48e2..80e197a 100644
---- a/numpy/distutils/system_info.py
-+++ b/numpy/distutils/system_info.py
-@@ -204,51 +204,13 @@ if sys.platform == 'win32':
+Index: numpy-1.13.1/numpy/distutils/system_info.py
+===================================================================
+--- numpy-1.13.1.orig/numpy/distutils/system_info.py
++++ numpy-1.13.1/numpy/distutils/system_info.py
+@@ -211,51 +211,13 @@ if sys.platform == 'win32':
default_x11_lib_dirs = []
default_x11_include_dirs = []
else:
@@ -29,7 +29,10 @@ index 9dd48e2..80e197a 100644
- '/opt/local/include', '/sw/include',
- '/usr/include/suitesparse']
- default_src_dirs = ['.', '/usr/local/src', '/opt/src', '/sw/src']
--
++ default_lib_dirs = libpaths(['/deadir/lib'], platform_bits)
++ default_include_dirs = ['/deaddir/include']
++ default_src_dirs = ['.', '/deaddir/src']
+
- default_x11_lib_dirs = libpaths(['/usr/X11R6/lib', '/usr/X11/lib',
- '/usr/lib'], platform_bits)
- default_x11_include_dirs = ['/usr/X11R6/include', '/usr/X11/include',
@@ -50,7 +53,7 @@ index 9dd48e2..80e197a 100644
- # tests are run in debug mode Python 3.
- tmp = open(os.devnull, 'w')
- p = sp.Popen(["gcc", "-print-multiarch"], stdout=sp.PIPE,
-- stderr=tmp)
+- stderr=tmp)
- except (OSError, DistutilsError):
- # OSError if gcc is not installed, or SandboxViolation (DistutilsError
- # subclass) if an old setuptools bug is triggered (see gh-3160).
@@ -64,15 +67,8 @@ index 9dd48e2..80e197a 100644
- finally:
- if tmp is not None:
- tmp.close()
-+ default_lib_dirs = libpaths(['/deadir/lib'], platform_bits)
-+ default_include_dirs = ['/deaddir/include']
-+ default_src_dirs = ['.', '/deaddir/src']
-+
+ default_x11_lib_dirs = libpaths(['/deaddir/lib'], platform_bits)
+ default_x11_include_dirs = ['/deaddir/include']
if os.path.join(sys.prefix, 'lib') not in default_lib_dirs:
default_lib_dirs.insert(0, os.path.join(sys.prefix, 'lib'))
---
-2.6.2
-
diff --git a/meta/recipes-devtools/python-numpy/python-numpy_1.11.2.bb b/meta/recipes-devtools/python-numpy/python-numpy_1.13.1.bb
index c4bc354036..63821d30fa 100644
--- a/meta/recipes-devtools/python-numpy/python-numpy_1.11.2.bb
+++ b/meta/recipes-devtools/python-numpy/python-numpy_1.13.1.bb
@@ -1,16 +1,20 @@
SUMMARY = "A sophisticated Numeric Processing Package for Python"
SECTION = "devel/python"
-LICENSE = "PSF"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7e51a5677b22b865abbfb3dff6ffb2d0"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1002b09cd654fcaa2dcc87535acd9a96"
SRCNAME = "numpy"
-SRC_URI = "https://files.pythonhosted.org/packages/source/n/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
file://remove-build-path-in-comments.patch \
file://fix_shebang_f2py.patch \
${CONFIGFILESURI} "
-UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/numpy/files/"
+
+SRC_URI[md5sum] = "6d459e4a24f5035f720dda3c57716a92"
+SRC_URI[sha256sum] = "de020ec06f1e9ce1115a50161a38bf8d4c2525379900f9cb478cc613a1e7cd93"
+
+UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
CONFIGFILESURI ?= ""
@@ -81,9 +85,6 @@ do_compile_prepend_class-target() {
FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
-SRC_URI[md5sum] = "03bd7927c314c43780271bf1ab795ebc"
-SRC_URI[sha256sum] = "04db2fbd64e2e7c68e740b14402b25af51418fc43a59d9e54172b38b906b0f69"
-
# install what is needed for numpy.test()
RDEPENDS_${PN} = "python-unittest \
python-difflib \
diff --git a/meta/recipes-devtools/python-numpy/python3-numpy_1.11.2.bb b/meta/recipes-devtools/python-numpy/python3-numpy_1.13.1.bb
index d5fe50c36f..0bf9e914f9 100644
--- a/meta/recipes-devtools/python-numpy/python3-numpy_1.11.2.bb
+++ b/meta/recipes-devtools/python-numpy/python3-numpy_1.13.1.bb
@@ -1,16 +1,19 @@
SUMMARY = "A sophisticated Numeric Processing Package for Python"
SECTION = "devel/python"
-LICENSE = "PSF"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7e51a5677b22b865abbfb3dff6ffb2d0"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1002b09cd654fcaa2dcc87535acd9a96"
SRCNAME = "numpy"
-SRC_URI = "https://files.pythonhosted.org/packages/source/n/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
file://remove-build-path-in-comments.patch \
file://fix_shebang_f2py.patch \
${CONFIGFILESURI} "
-UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/numpy/files/"
+SRC_URI[md5sum] = "6d459e4a24f5035f720dda3c57716a92"
+SRC_URI[sha256sum] = "de020ec06f1e9ce1115a50161a38bf8d4c2525379900f9cb478cc613a1e7cd93"
+
+UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
CONFIGFILESURI ?= ""
@@ -81,9 +84,6 @@ do_compile_prepend_class-target() {
FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
-SRC_URI[md5sum] = "03bd7927c314c43780271bf1ab795ebc"
-SRC_URI[sha256sum] = "04db2fbd64e2e7c68e740b14402b25af51418fc43a59d9e54172b38b906b0f69"
-
# install what is needed for numpy.test()
RDEPENDS_${PN} = "python3-unittest \
python3-difflib \