aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-14 14:00:21 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-06 17:01:03 +0100
commitee006aac0a52709cf5524aeb17a92b8c5c44be34 (patch)
tree436f0a8e6ae79d7be64a9090da1e18484965a5a1
parent1009498f23ad319825c00ba60a4693d15aada553 (diff)
downloadopenembedded-core-contrib-ee006aac0a52709cf5524aeb17a92b8c5c44be34.tar.gz
python3-native: Avoid use of getentropy/getrandom
getentropy/random() is only available in glibc 2.25+ and uninative may relocate binaries onto systems that don't have this function. For now, force the code to the older codepaths until we can come up with a better solution for this kind of issue. (From OE-Core rev: 92bda0024d85ae78345665cc2f9646c9881ed61b) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3-native_3.5.2.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.5.2.bb b/meta/recipes-devtools/python/python3-native_3.5.2.bb
index edcf2244f5..3f4b567278 100644
--- a/meta/recipes-devtools/python/python3-native_3.5.2.bb
+++ b/meta/recipes-devtools/python/python3-native_3.5.2.bb
@@ -43,7 +43,8 @@ inherit native
require python-native-${PYTHON_MAJMIN}-manifest.inc
-EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --without-ensurepip"
+# uninative may be used on pre glibc 2.25 systems which don't have getentropy
+EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --without-ensurepip ac_cv_func_getentropy=no"
EXTRA_OEMAKE = '\
LIBC="" \
@@ -58,6 +59,7 @@ PYTHONLSBOPTS = ""
do_configure_append() {
autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
+ sed -i -e 's,#define HAVE_GETRANDOM 1,/\* #undef HAVE_GETRANDOM \*/,' ${B}/pyconfig.h
}
do_install() {