aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2017-07-17 14:30:26 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-27 22:35:10 +0100
commit89d53c742d3538744b892237698ffde2c9c60009 (patch)
treeb255dcfb6d87aba71fb55c8a6c27e92539cff9ac
parenta6eaef0f179a341c0b96bb30aaec2d80862a11d6 (diff)
downloadopenembedded-core-contrib-89d53c742d3538744b892237698ffde2c9c60009.tar.gz
systemd: workaround login failure on qemumips64 when 'pam' is enabled
Append " -fno-tree-switch-conversion -fno-tree-tail-merge" to FULL_OPTIMIZATION to workaround login problem on qemumips64. Otherwise, user cannot login onto the target even username and password are provided. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> (cherry picked from commit 35403ba3707c3c8dd94bcc557eef6f7c66696bc5) Hand applied Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-core/systemd/systemd_232.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_232.bb b/meta/recipes-core/systemd/systemd_232.bb
index e54c723d7f..25fe496417 100644
--- a/meta/recipes-core/systemd/systemd_232.bb
+++ b/meta/recipes-core/systemd/systemd_232.bb
@@ -161,6 +161,9 @@ CFLAGS .= "${@bb.utils.contains('PACKAGECONFIG', 'valgrind', ' -DVALGRIND=1', ''
# disable problematic GCC 5.2 optimizations [YOCTO #8291]
FULL_OPTIMIZATION_append_arm = " -fno-schedule-insns -fno-schedule-insns2"
+# Avoid login failure on qemumips64 when pam is enabled
+FULL_OPTIMIZATION_append_mips64 = " -fno-tree-switch-conversion -fno-tree-tail-merge"
+
do_configure_prepend() {
export NM="${HOST_PREFIX}gcc-nm"
export AR="${HOST_PREFIX}gcc-ar"