aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-07-24 18:58:25 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-29 11:54:26 +0100
commit4d965cdb451f87ee7f9364d71e2eea94cf04d3ed (patch)
tree48cc86b25bc74ad8579d27abdbc60e6ca188b33e
parent421850875a5dafa1deed0647b7b30b76df9b25cf (diff)
downloadopenembedded-core-contrib-4d965cdb451f87ee7f9364d71e2eea94cf04d3ed.tar.gz
systemtap: ensure systemtap-native is available
Since we are adding the addto_sysroot that that is specific to the native recipe, we must split this into a seperate -native .bb recipe. When systemtap-native is built, the intention is that it's usable from the native sysroot when done, ensure it's there with a forced addto_recipe_sysroot task, we also don't want to clean the sysroot when RM_WORK is enabled otherwise we loose the binaries. [YOCTO #11403] Signed-off-by: Saul Wold <sgw@linux.intel.com> (cherry picked from commit 2fdb59741b4fdeaa4aee10812c4a409cdc11a02d) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 98fba18e93abe8efce0a5b40d51e178c9de4d1e5) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-kernel/systemtap/systemtap-native_git.bb7
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb2
2 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap-native_git.bb b/meta/recipes-kernel/systemtap/systemtap-native_git.bb
new file mode 100644
index 0000000000..c3da77c831
--- /dev/null
+++ b/meta/recipes-kernel/systemtap/systemtap-native_git.bb
@@ -0,0 +1,7 @@
+
+require systemtap_git.bb
+
+inherit native
+
+RM_WORK_EXCLUDE_ITEMS += "recipe-sysroot-native"
+addtask addto_recipe_sysroot after do_populate_sysroot before do_build
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index fed368a38b..b3fd9730da 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -25,4 +25,4 @@ PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,
inherit autotools gettext pkgconfig distutils3-base
-BBCLASSEXTEND = "native nativesdk"
+BBCLASSEXTEND = "nativesdk"