aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-08-07 23:47:57 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-10 10:45:31 +0100
commita18457e3318da21b642018897a0df29cb543deea (patch)
treefa76f86556e060987707f2141d8e5fe249195d60
parent1d45b7bd611b900bc00530144ec0634307b1314f (diff)
downloadopenembedded-core-contrib-a18457e3318da21b642018897a0df29cb543deea.tar.gz
strace: Fix build with mips/mips64 on musl
SIGEMT doesnt exist on musl Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/strace/strace/mips-SIGEMT.patch24
-rw-r--r--meta/recipes-devtools/strace/strace_4.13.bb1
2 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace/mips-SIGEMT.patch b/meta/recipes-devtools/strace/strace/mips-SIGEMT.patch
new file mode 100644
index 0000000000..b24378bfee
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace/mips-SIGEMT.patch
@@ -0,0 +1,24 @@
+SIGEMT is not defined everywhere e.g musl does
+not define it. Therefore check it being defined
+before using it.
+
+Fixes errors e.g.
+../../strace-4.13/tests/signal2name.c:45:7: error: 'SIGEMT' undeclared (first use in this function)
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Pending
+
+Index: strace-4.13/tests/signal2name.c
+===================================================================
+--- strace-4.13.orig/tests/signal2name.c
++++ strace-4.13/tests/signal2name.c
+@@ -42,7 +42,9 @@ signal2name(int sig)
+ CASE(SIGEMT);
+ CASE(SIGLOST);
+ #elif defined MIPS
++#ifdef SIGEMT
+ CASE(SIGEMT);
++#endif
+ CASE(SIGIOT);
+ CASE(SIGPWR);
+ #else
diff --git a/meta/recipes-devtools/strace/strace_4.13.bb b/meta/recipes-devtools/strace/strace_4.13.bb
index 51ff41eb67..cae7f2138e 100644
--- a/meta/recipes-devtools/strace/strace_4.13.bb
+++ b/meta/recipes-devtools/strace/strace_4.13.bb
@@ -12,6 +12,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
file://Makefile-ptest.patch \
file://run-ptest \
file://0001-Fix-build-when-using-non-glibc-libc-implementation-o.patch \
+ file://mips-SIGEMT.patch \
"
SRC_URI[md5sum] = "4b78c7febdd24c79d5147824d1a080a3"