aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2017-06-09 21:34:33 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-12 15:17:50 +0100
commit7e0964e506506d20a25aac570104938759f9f70e (patch)
tree6407c1e0e5c3f357ab7f59be9aac30a66a234c26
parent74d040f456269992a13850a626279b3b8e954847 (diff)
downloadopenembedded-core-contrib-7e0964e506506d20a25aac570104938759f9f70e.tar.gz
rpm: Use conditional to access %{_docdir} in macros.in
This avoids the following warning: warning: Ignoring invalid regex %{_docdir} when runing `rpmdeps -R <file>`, since %{_docdir} is only defined when parsing a spec file. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/rpm/files/0012-Use-conditional-to-access-_docdir-in-macros.in.patch36
-rw-r--r--meta/recipes-devtools/rpm/rpm_git.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/files/0012-Use-conditional-to-access-_docdir-in-macros.in.patch b/meta/recipes-devtools/rpm/files/0012-Use-conditional-to-access-_docdir-in-macros.in.patch
new file mode 100644
index 0000000000..996da90d43
--- /dev/null
+++ b/meta/recipes-devtools/rpm/files/0012-Use-conditional-to-access-_docdir-in-macros.in.patch
@@ -0,0 +1,36 @@
+From 77808db4036dc4a012c47aca36255549ed764a6a Mon Sep 17 00:00:00 2001
+From: Peter Kjellerstedt <pkj@axis.com>
+Date: Tue, 16 May 2017 10:58:18 +0200
+Subject: [PATCH 12/13] Use conditional to access %{_docdir} in macros.in
+
+This avoids the following warning:
+
+warning: Ignoring invalid regex %{_docdir}
+
+when runing `rpmdeps -R <file>`, since %{_docdir} is only defined when
+parsing a spec file (in parseSpec()).
+
+Upstream-Status: Accepted [https://github.com/rpm-software-management/rpm/pull/216]
+Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
+---
+ macros.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/macros.in b/macros.in
+index 84ae25275..cca67a500 100644
+--- a/macros.in
++++ b/macros.in
+@@ -200,8 +200,8 @@ package or when debugging this package.\
+ # Their purpouse is to set up global filtering for all packages. If you need
+ # to set up specific filtering for your package use %__requires_exclude_from
+ # and %__provides_exclude_from instead.
+-%__global_requires_exclude_from %{_docdir}
+-%__global_provides_exclude_from %{_docdir}
++%__global_requires_exclude_from %{?_docdir:%{_docdir}}
++%__global_provides_exclude_from %{?_docdir:%{_docdir}}
+
+ # The path to the gzip executable (legacy, use %{__gzip} instead).
+ %_gzipbin %{__gzip}
+--
+2.12.0
+
diff --git a/meta/recipes-devtools/rpm/rpm_git.bb b/meta/recipes-devtools/rpm/rpm_git.bb
index 15880377b8..7c5f649a8b 100644
--- a/meta/recipes-devtools/rpm/rpm_git.bb
+++ b/meta/recipes-devtools/rpm/rpm_git.bb
@@ -36,6 +36,7 @@ SRC_URI = "git://github.com/rpm-software-management/rpm \
file://0001-Add-a-color-setting-for-mips64_n32-binaries.patch \
file://0001-Add-PYTHON_ABI-when-searching-for-python-libraries.patch \
file://0011-Do-not-require-that-ELF-binaries-are-executable-to-b.patch \
+ file://0012-Use-conditional-to-access-_docdir-in-macros.in.patch \
"
PV = "4.13.90+git${SRCPV}"