summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLee Chee Yang <chee.yang.lee@intel.com>2020-11-18 21:22:25 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-24 10:27:38 +0000
commitad6b184b5a87b8bcdd5e28f19be841a78f5e51df (patch)
tree3150032a29dbd22fcabd1eb0192960d1a3dc8e02
parentef675b44ae6b211cf64425d94d46cc1aa961d2cc (diff)
downloadopenembedded-core-contrib-ad6b184b5a87b8bcdd5e28f19be841a78f5e51df.tar.gz
python3: fix CVE-2020-27619
Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3/CVE-2020-27619.patch69
-rw-r--r--meta/recipes-devtools/python/python3_3.9.0.bb1
2 files changed, 70 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3/CVE-2020-27619.patch b/meta/recipes-devtools/python/python3/CVE-2020-27619.patch
new file mode 100644
index 0000000000..b2053e7a47
--- /dev/null
+++ b/meta/recipes-devtools/python/python3/CVE-2020-27619.patch
@@ -0,0 +1,69 @@
+From b664a1df4ee71d3760ab937653b10997081b1794 Mon Sep 17 00:00:00 2001
+From: "Miss Skeleton (bot)" <31488909+miss-islington@users.noreply.github.com>
+Date: Tue, 6 Oct 2020 05:37:36 -0700
+Subject: [PATCH] bpo-41944: No longer call eval() on content received via HTTP
+ in the CJK codec tests (GH-22566)
+
+(cherry picked from commit 2ef5caa58febc8968e670e39e3d37cf8eef3cab8)
+
+Co-authored-by: Serhiy Storchaka <storchaka@gmail.com>
+
+Upstream-Status: Backport [https://github.com/python/cpython/commit/b664a1df4ee71d3760ab937653b10997081b1794]
+CVE: CVE-2020-27619
+Signed-off-by: Chee Yang Lee <chee.yang.lee@intel.com>
+
+---
+ Lib/test/multibytecodec_support.py | 22 +++++++------------
+ .../2020-10-05-17-43-46.bpo-41944.rf1dYb.rst | 1 +
+ 2 files changed, 9 insertions(+), 14 deletions(-)
+ create mode 100644 Misc/NEWS.d/next/Tests/2020-10-05-17-43-46.bpo-41944.rf1dYb.rst
+
+diff --git a/Lib/test/multibytecodec_support.py b/Lib/test/multibytecodec_support.py
+index cca8af67d6d1d..f76c0153f5ecf 100644
+--- a/Lib/test/multibytecodec_support.py
++++ b/Lib/test/multibytecodec_support.py
+@@ -305,29 +305,23 @@ def test_mapping_file(self):
+ self._test_mapping_file_plain()
+
+ def _test_mapping_file_plain(self):
+- unichrs = lambda s: ''.join(map(chr, map(eval, s.split('+'))))
++ def unichrs(s):
++ return ''.join(chr(int(x, 16)) for x in s.split('+'))
++
+ urt_wa = {}
+
+ with self.open_mapping_file() as f:
+ for line in f:
+ if not line:
+ break
+- data = line.split('#')[0].strip().split()
++ data = line.split('#')[0].split()
+ if len(data) != 2:
+ continue
+
+- csetval = eval(data[0])
+- if csetval <= 0x7F:
+- csetch = bytes([csetval & 0xff])
+- elif csetval >= 0x1000000:
+- csetch = bytes([(csetval >> 24), ((csetval >> 16) & 0xff),
+- ((csetval >> 8) & 0xff), (csetval & 0xff)])
+- elif csetval >= 0x10000:
+- csetch = bytes([(csetval >> 16), ((csetval >> 8) & 0xff),
+- (csetval & 0xff)])
+- elif csetval >= 0x100:
+- csetch = bytes([(csetval >> 8), (csetval & 0xff)])
+- else:
++ if data[0][:2] != '0x':
++ self.fail(f"Invalid line: {line!r}")
++ csetch = bytes.fromhex(data[0][2:])
++ if len(csetch) == 1 and 0x80 <= csetch[0]:
+ continue
+
+ unich = unichrs(data[1])
+diff --git a/Misc/NEWS.d/next/Tests/2020-10-05-17-43-46.bpo-41944.rf1dYb.rst b/Misc/NEWS.d/next/Tests/2020-10-05-17-43-46.bpo-41944.rf1dYb.rst
+new file mode 100644
+index 0000000000000..4f9782f1c85af
+--- /dev/null
++++ b/Misc/NEWS.d/next/Tests/2020-10-05-17-43-46.bpo-41944.rf1dYb.rst
+@@ -0,0 +1 @@
++Tests for CJK codecs no longer call ``eval()`` on content received via HTTP.
diff --git a/meta/recipes-devtools/python/python3_3.9.0.bb b/meta/recipes-devtools/python/python3_3.9.0.bb
index 8fe60ea016..ae9a974f04 100644
--- a/meta/recipes-devtools/python/python3_3.9.0.bb
+++ b/meta/recipes-devtools/python/python3_3.9.0.bb
@@ -29,6 +29,7 @@ SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
file://0001-Makefile-do-not-compile-.pyc-in-parallel.patch \
file://0020-configure.ac-setup.py-do-not-add-a-curses-include-pa.patch \
file://0001-Lib-sysconfig.py-use-libdir-values-from-configuratio.patch \
+ file://CVE-2020-27619.patch \
"
SRC_URI_append_class-native = " \