summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-12-15 23:40:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-12-17 09:56:09 +0000
commit742042ca1a3d0bbb9736513cf2c9629221c8d84b (patch)
tree341fe8fd9a4a1974f81ee03ce19ccf738a68b2ec
parent35ab4d42d557d5810b41bf2cc681d67da9213829 (diff)
downloadopenembedded-core-contrib-742042ca1a3d0bbb9736513cf2c9629221c8d84b.tar.gz
debianutils: update 4.11.2 -> 5.5
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/debianutils/debianutils_5.5.bb (renamed from meta/recipes-support/debianutils/debianutils_4.11.2.bb)20
1 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-support/debianutils/debianutils_4.11.2.bb b/meta/recipes-support/debianutils/debianutils_5.5.bb
index 231666c4dc..6eea86f6d3 100644
--- a/meta/recipes-support/debianutils/debianutils_4.11.2.bb
+++ b/meta/recipes-support/debianutils/debianutils_5.5.bb
@@ -8,25 +8,26 @@ SECTION = "base"
LICENSE = "GPLv2 & SMAIL_GPL"
LIC_FILES_CHKSUM = "file://debian/copyright;md5=9b912cd0cc654134c0ef3424a0705b94"
-SRC_URI = "http://snapshot.debian.org/archive/debian/20200929T025235Z/pool/main/d/${BPN}/${BPN}_${PV}.tar.xz"
-# the package is taken from snapshots.debian.org; that source is static and goes stale
-# so we check the latest upstream from a directory that does get updated
-UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/"
+SRC_URI = "git://salsa.debian.org/debian/debianutils.git;protocol=https;branch=master \
+ "
-SRC_URI[sha256sum] = "3b680e81709b740387335fac8f8806d71611dcf60874e1a792e862e48a1650de"
+SRCREV = "4c420893485ad07d771c327ef899819d4846408f"
inherit autotools update-alternatives
-S = "${WORKDIR}/debianutils"
+S = "${WORKDIR}/git"
+
+# Disable po4a (translated manpages) sub-directory, as that requires po4a to build
do_configure:prepend() {
- sed -i -e 's:tempfile.1 which.1:which.1:g' ${S}/Makefile.am
+ sed -i -e 's:po4a::g' ${S}/Makefile.am
}
+
do_install:append() {
if [ "${base_bindir}" != "${bindir}" ]; then
# Debian places some utils into ${base_bindir} as does busybox
install -d ${D}${base_bindir}
- for app in run-parts tempfile; do
+ for app in run-parts; do
mv ${D}${bindir}/$app ${D}${base_bindir}/$app
done
fi
@@ -41,7 +42,7 @@ RDEPENDS:${PN} += "${PN}-run-parts"
RDEPENDS:${PN}:class-native = ""
ALTERNATIVE_PRIORITY = "30"
-ALTERNATIVE:${PN} = "add-shell installkernel remove-shell savelog tempfile which"
+ALTERNATIVE:${PN} = "add-shell installkernel remove-shell savelog which"
ALTERNATIVE_PRIORITY_${PN}-run-parts = "60"
ALTERNATIVE:${PN}-run-parts = "run-parts"
@@ -54,7 +55,6 @@ ALTERNATIVE_LINK_NAME[installkernel] = "${sbindir}/installkernel"
ALTERNATIVE_LINK_NAME[remove-shell] = "${sbindir}/remove-shell"
ALTERNATIVE_LINK_NAME[run-parts] = "${base_bindir}/run-parts"
ALTERNATIVE_LINK_NAME[savelog] = "${bindir}/savelog"
-ALTERNATIVE_LINK_NAME[tempfile] = "${base_bindir}/tempfile"
ALTERNATIVE_LINK_NAME[which] = "${bindir}/which"
BBCLASSEXTEND = "native"