summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Rowe <rrowe@xevo.com>2020-06-12 12:48:24 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-16 15:20:01 +0100
commit21446d4b6c5f59b6acb66133a9675ec3d3dbabe2 (patch)
treef54037c8d45951bc1304410e07bf7416224d69f6
parenta14b274b56676ff0ba55a4048169ad60c9514994 (diff)
downloadopenembedded-core-contrib-21446d4b6c5f59b6acb66133a9675ec3d3dbabe2.tar.gz
python3: fix PGO for non-reproducible biniaries
When PGO was disabled by default by e53ebf29, a bug was introduced that prevented PGO from ever being enabled. At the time at which extra config is appended to PACKAGECONFIG_CONFARGS, PACKAGECONFIG_PGO remains unevaluated in PACKAGECONFIG_class-target, due to setting its value in an anonymous Python function. As a result, the PGO options options will never be included. Signed-off-by: Ryan Rowe <rrowe@xevo.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3_3.8.3.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-devtools/python/python3_3.8.3.bb b/meta/recipes-devtools/python/python3_3.8.3.bb
index 997308dc75..2eb2a422e6 100644
--- a/meta/recipes-devtools/python/python3_3.8.3.bb
+++ b/meta/recipes-devtools/python/python3_3.8.3.bb
@@ -82,16 +82,16 @@ CACHED_CONFIGUREVARS = " \
ac_cv_file__dev_ptc=no \
ac_cv_working_tzset=yes \
"
-python() {
+
+def possibly_include_pgo(d):
# PGO currently causes builds to not be reproducible, so disable it for
# now. See YOCTO #13407
if bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', True, False, d) and d.getVar('BUILD_REPRODUCIBLE_BINARIES') != '1':
- d.setVar('PACKAGECONFIG_PGO', 'pgo')
- else:
- d.setVar('PACKAGECONFIG_PGO', '')
-}
+ return 'pgo'
+
+ return ''
-PACKAGECONFIG_class-target ??= "readline ${PACKAGECONFIG_PGO} gdbm"
+PACKAGECONFIG_class-target ??= "readline ${@possibly_include_pgo(d)} gdbm"
PACKAGECONFIG_class-native ??= "readline gdbm"
PACKAGECONFIG_class-nativesdk ??= "readline gdbm"
PACKAGECONFIG[readline] = ",,readline"