aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-07-18 14:54:48 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-20 10:24:56 +0100
commitd02a3a745fbb7b534f22de861e7a43e7dacc7970 (patch)
treef969300222ed3fd1a226a42da67d45b8c6e52124
parentc9bef2ecf1a30159d11781184829f41844a58c13 (diff)
downloadopenembedded-core-contrib-d02a3a745fbb7b534f22de861e7a43e7dacc7970.tar.gz
mesa-demos: Require X11 distro feature
Mesa-demos theoretically does not require X11 (apart from xdemos/) but reality is that every other binary requires glut. So: * 'non-glut' part of mesa-demos requires X11 * current freeglut recipe also depends on X11 There is apparently wayland support in freeglut now: This recipe should be modified when meta-oe freeglut recipe has that feature. The change became necessary now because mesa no longer mistakenly installs GL files when X11 is disabled (and mesa-demos configure currently requires GL). Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb b/meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb
index ee0bb020a3..fab0bdb2ee 100644
--- a/meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb
+++ b/meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb
@@ -24,10 +24,10 @@ SRC_URI[sha256sum] = "c173154bbd0d5fb53d732471984def42fb1b14ac85fcb834138fb9518b
inherit autotools pkgconfig distro_features_check
# depends on virtual/egl, virtual/libgl ...
-REQUIRED_DISTRO_FEATURES = "opengl"
+REQUIRED_DISTRO_FEATURES = "opengl x11"
PACKAGECONFIG ?= "drm osmesa freetype2 gbm egl gles1 gles2 \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 glew glu glx', '', d)}"
+ x11 glew glu glx"
# The Wayland code doesn't work with Wayland 1.0, so disable it for now
#${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"