summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-09-20 13:43:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-22 17:14:42 +0100
commitb12d99dbfbee8c4b3680f453f833410950238bb9 (patch)
treec49c097db0d5f1957b6d72166ab2200f2c3c60c6
parentdf5ae8143ff1764b6ed5973ed3d6f1a83ecf45ee (diff)
downloadopenembedded-core-contrib-b12d99dbfbee8c4b3680f453f833410950238bb9.tar.gz
openembedded-core-contrib-b12d99dbfbee8c4b3680f453f833410950238bb9.tar.bz2
openembedded-core-contrib-b12d99dbfbee8c4b3680f453f833410950238bb9.zip
sanity: correct Python version sanity check
We now require Python 3.4, not 2.7. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/classes/sanity.bbclass6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/classes/sanity.bbclass b/meta/classes/sanity.bbclass
index 5699287a4a..91b92ec28a 100644
--- a/meta/classes/sanity.bbclass
+++ b/meta/classes/sanity.bbclass
@@ -702,10 +702,10 @@ def check_sanity_everybuild(status, d):
if 0 == os.getuid():
raise_sanity_error("Do not use Bitbake as root.", d)
- # Check the Python version, we now have a minimum of Python 2.7.3
+ # Check the Python version, we now have a minimum of Python 3.4
import sys
- if sys.hexversion < 0x020703F0:
- status.addresult('The system requires at least Python 2.7.3 to run. Please update your Python interpreter.\n')
+ if sys.hexversion < 0x03040000:
+ status.addresult('The system requires at least Python 3.4 to run. Please update your Python interpreter.\n')
# Check the bitbake version meets minimum requirements
from distutils.version import LooseVersion