aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrian avery <brian.avery@intel.com>2017-04-12 23:40:56 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-04-12 23:55:54 +0100
commit2e7a155774952705d21109720985f6833fba2669 (patch)
treee8e06cbc5be5bcac6b99ee921a494d409a0aca2c
parentc2da28fd955901b1be9a155c5ca256345fdcee43 (diff)
downloadopenembedded-core-contrib-2e7a155774952705d21109720985f6833fba2669.tar.gz
qemu-helper-native: prepare native sysroot for runqemu
Make sure that native sysroot contains qemu and tunctl binaries for runqemu usage: - excluded native sysroot from rm_work - added qemu-native to DEPENDS to put qemu binaries into native sysroot - forced addto_recipe_sysroot task [YOCTO #11266] [YOCTO #11193] Signed-off-by: brian avery <brian.avery@intel.com> Signed-off-by: Ed Bartosh <ed.bartosh@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb b/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb
index 8d27c4db61..27d53157db 100644
--- a/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb
+++ b/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb
@@ -19,3 +19,7 @@ do_install() {
install -d ${D}${bindir}
install tunctl ${D}${bindir}/
}
+
+RM_WORK_EXCLUDE_ITEMS += "recipe-sysroot-native"
+DEPENDS += "qemu-native"
+addtask addto_recipe_sysroot after do_populate_sysroot before do_build