aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-02-01 10:30:36 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-05 09:20:21 +0000
commit3fac012408e4f6aac6520539bc6c6b0d59e2e629 (patch)
treea43c57b2f06f82083ada3ffd5f203c21e802f25f
parent1003615b866bfe196994bdc25d305ff5eace2715 (diff)
downloadopenembedded-core-contrib-3fac012408e4f6aac6520539bc6c6b0d59e2e629.tar.gz
linux-yocto/4.9: yaffs2 fixes
Merging three fixes to yaffs2, which adjust to mainline changes in the vfs subsystem: 4700f2f8b9db fs: yaffs2: fix the prototype of function yaffs_rename() 56e654cab1db fs: yaffs2: switch to the generic xattr handler 102082f3c245 fs/yaffs2: adjust to the change of inode_change_ok() Signed-off-by: Kevin Hao <kexin.hao@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.9.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.9.bb18
3 files changed, 13 insertions, 13 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.9.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.9.bb
index b2986e32af..8eaec528d6 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.9.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.9.bb
@@ -11,8 +11,8 @@ python () {
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "35cfaa68bf6ceaf59cf2bcd020d4e66155e19c46"
-SRCREV_meta ?= "3715fc90f7b69de59ca0870f6c7cda27cdc0f895"
+SRCREV_machine ?= "71569cd064e02564211737430c31a4b0e9c810fb"
+SRCREV_meta ?= "6fd9dcbb3f0becf90c555a1740d21d18c331af99"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.9.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb
index a9d17549d6..5510b0f8ff 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.9.bb
@@ -9,8 +9,8 @@ LINUX_VERSION ?= "4.9.6"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "0b52a52fb892c0dd20823268830ab22a9e3a92b8"
-SRCREV_meta ?= "3715fc90f7b69de59ca0870f6c7cda27cdc0f895"
+SRCREV_machine ?= "4700f2f8b9dbaad5ae441b682d04b09e811135fc"
+SRCREV_meta ?= "6fd9dcbb3f0becf90c555a1740d21d18c331af99"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.9.bb b/meta/recipes-kernel/linux/linux-yocto_4.9.bb
index e5f6064fc9..a7593848f6 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.9.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.9.bb
@@ -11,15 +11,15 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "9dc59f0efe6cd1dd806b5b6089faf803db9018a4"
-SRCREV_machine_qemuarm64 ?= "0b52a52fb892c0dd20823268830ab22a9e3a92b8"
-SRCREV_machine_qemumips ?= "0ed887a8c24e2c2a8a2f136b9ef5031bdf6cde8c"
-SRCREV_machine_qemuppc ?= "0b52a52fb892c0dd20823268830ab22a9e3a92b8"
-SRCREV_machine_qemux86 ?= "0b52a52fb892c0dd20823268830ab22a9e3a92b8"
-SRCREV_machine_qemux86-64 ?= "0b52a52fb892c0dd20823268830ab22a9e3a92b8"
-SRCREV_machine_qemumips64 ?= "06fff8284bbec52a36fb3d054354db2f593376ac"
-SRCREV_machine ?= "0b52a52fb892c0dd20823268830ab22a9e3a92b8"
-SRCREV_meta ?= "3715fc90f7b69de59ca0870f6c7cda27cdc0f895"
+SRCREV_machine_qemuarm ?= "103383d270939399bc73365c31cd6f93c567114f"
+SRCREV_machine_qemuarm64 ?= "4700f2f8b9dbaad5ae441b682d04b09e811135fc"
+SRCREV_machine_qemumips ?= "c8425cad333ec85f61d63054051fe17df53ece29"
+SRCREV_machine_qemuppc ?= "4700f2f8b9dbaad5ae441b682d04b09e811135fc"
+SRCREV_machine_qemux86 ?= "4700f2f8b9dbaad5ae441b682d04b09e811135fc"
+SRCREV_machine_qemux86-64 ?= "4700f2f8b9dbaad5ae441b682d04b09e811135fc"
+SRCREV_machine_qemumips64 ?= "42fe7d605fc92985c8ba10363de487ea06bd068a"
+SRCREV_machine ?= "4700f2f8b9dbaad5ae441b682d04b09e811135fc"
+SRCREV_meta ?= "6fd9dcbb3f0becf90c555a1740d21d18c331af99"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.9.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA}"