aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-09-27 16:41:17 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-30 22:01:32 +0100
commitd856488179d14d05f1121c171abf4eac82e81fb9 (patch)
treec854233f081626d2e85a0e55f0dc5deab18c53f7
parent778ef56c4b5c0d450a9b2e1df2b3e963dcfebed9 (diff)
downloadopenembedded-core-contrib-d856488179d14d05f1121c171abf4eac82e81fb9.tar.gz
sato-icon-theme: add more compatibility symlinks
libfm uses "preferences-desktop", so link it to the close-enough "preferences-sytem". x11vnc uses "computer", link it to "terminal". pcmanfm uses "system-file-manager", link it to "file-manager". [ YOCTO #4062 ] Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb b/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb
index cb3b68c16e..cf23aebf5e 100644
--- a/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb
+++ b/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb
@@ -23,6 +23,12 @@ FILES_${PN} += "${datadir}"
EXTRA_OECONF += "--with-iconmap=${@d.getVar('STAGING_LIBEXECDIR_NATIVE', True).replace('sato-icon-theme', 'icon-naming-utils')}/icon-name-mapping"
+do_install_append() {
+ find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s preferences-system.png {}/apps/preferences-desktop.png \;
+ find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s file-manager.png {}/apps/system-file-manager.png \;
+ find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s ../apps/terminal.png {}/places/computer.png \;
+}
+
# Explictly setting "Sato" as the default icon theme to avoid flickering from
# the desktop and settings daemon racing. This shouldn't be done here but in the sato image
pkg_postinst_${PN} () {