aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnders Roxell <anders.roxell@linaro.org>2018-02-08 18:34:59 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-16 18:05:28 +0000
commitcf355518a479b75f3cbf57770ba0f699f85678d8 (patch)
treef30774a4485d08713861766742cede8ca8f3bafc
parent9603f352a7d0c1e262d3bac0d6c137cf370dee15 (diff)
downloadopenembedded-core-contrib-cf355518a479b75f3cbf57770ba0f699f85678d8.tar.gz
ltp: fix knob to control numa support
Reported-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Anders Roxell <anders.roxell@linaro.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-extended/ltp/ltp/0001-configure-Fix-default-value-of-without-numa-switch-i.patch31
-rw-r--r--meta/recipes-extended/ltp/ltp/0001-configure-add-knob-to-control-numa-support.patch50
-rw-r--r--meta/recipes-extended/ltp/ltp/0002-Add-knob-to-control-whether-numa-support-should-be-c.patch45
-rw-r--r--meta/recipes-extended/ltp/ltp_20180118.bb3
4 files changed, 83 insertions, 46 deletions
diff --git a/meta/recipes-extended/ltp/ltp/0001-configure-Fix-default-value-of-without-numa-switch-i.patch b/meta/recipes-extended/ltp/ltp/0001-configure-Fix-default-value-of-without-numa-switch-i.patch
new file mode 100644
index 0000000000..da62687d57
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp/0001-configure-Fix-default-value-of-without-numa-switch-i.patch
@@ -0,0 +1,31 @@
+From 4ace68a6ba501907a0741dba5f5f155e06a74c35 Mon Sep 17 00:00:00 2001
+From: Petr Vorel <pvorel@suse.cz>
+Date: Wed, 7 Feb 2018 11:09:49 +0100
+Subject: [PATCH] configure: Fix default value of --without-numa switch in help
+
+The default value is no.
+
+Fixes: 39a85a1f1 ("configure: add knob to control numa support")
+
+Signed-off-by: Petr Vorel <pvorel@suse.cz>
+Upstream-Status: Accepted
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index b39a31d..d66ea00 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -86,7 +86,7 @@ fi
+ # Numa
+ AC_ARG_WITH([numa],
+ AC_HELP_STRING([--without-numa],
+- [without numa support (default=yes)]),
++ [without numa support (default=no)]),
+ [with_numa=no],
+ [with_numa=yes]
+ )
+--
+2.7.4
+
diff --git a/meta/recipes-extended/ltp/ltp/0001-configure-add-knob-to-control-numa-support.patch b/meta/recipes-extended/ltp/ltp/0001-configure-add-knob-to-control-numa-support.patch
new file mode 100644
index 0000000000..8aaa287b76
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp/0001-configure-add-knob-to-control-numa-support.patch
@@ -0,0 +1,50 @@
+From 39a85a1f1e6624f554215ba4b6843d3689a8415e Mon Sep 17 00:00:00 2001
+From: Anders Roxell <anders.roxell@linaro.org>
+Date: Mon, 5 Feb 2018 11:56:04 +0100
+Subject: [PATCH] configure: add knob to control numa support
+
+Allow to disable numa from the top level.
+
+Based on patch:
+http://cgit.openembedded.org/openembedded-core/commit/meta/recipes-extended/ltp?id=4c7873552e13dfdba96afca7562c398d2966ca71
+
+Reported-by: Roy Li <rongqing.li@windriver.com>
+Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
+Signed-off-by: Petr Vorel <pvorel@suse.cz>
+Upstream-Status: Accepted
+---
+ configure.ac | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 5c8d4ea..b39a31d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -83,6 +83,14 @@ else
+ AC_SUBST([WITH_EXPECT],["no"])
+ fi
+
++# Numa
++AC_ARG_WITH([numa],
++ AC_HELP_STRING([--without-numa],
++ [without numa support (default=yes)]),
++ [with_numa=no],
++ [with_numa=yes]
++)
++
+ # Perl
+ AC_ARG_WITH([perl],
+ [AC_HELP_STRING([--with-perl],
+@@ -157,7 +165,9 @@ LTP_CHECK_SELINUX
+ LTP_CHECK_SIGNAL
+ LTP_CHECK_SYSCALL_EVENTFD
+ LTP_CHECK_SYSCALL_MODIFY_LDT
++if test "x$with_numa" = xyes; then
+ LTP_CHECK_SYSCALL_NUMA
++fi
+ LTP_CHECK_SYSCALL_QUOTACTL
+ LTP_CHECK_SYSCALL_SIGNALFD
+ LTP_CHECK_SYSCALL_UNSHARE
+--
+2.7.4
+
diff --git a/meta/recipes-extended/ltp/ltp/0002-Add-knob-to-control-whether-numa-support-should-be-c.patch b/meta/recipes-extended/ltp/ltp/0002-Add-knob-to-control-whether-numa-support-should-be-c.patch
deleted file mode 100644
index 31460b9089..0000000000
--- a/meta/recipes-extended/ltp/ltp/0002-Add-knob-to-control-whether-numa-support-should-be-c.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 867ad5d5d64b9b27ee32148027532db0a00f6433 Mon Sep 17 00:00:00 2001
-From: "Roy.Li" <rongqing.li@windriver.com>
-Date: Thu, 7 Jan 2016 17:33:26 +0000
-Subject: [PATCH 02/32] Add knob to control whether numa support should be
- checked
-
-otherwise undeterministic dependency will be generated
-during build depending upong numa being staged or not
-
-Signed-off-by: Roy.Li <rongqing.li@windriver.com>
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
-Upstream-Status: Pending
----
- m4/ltp-numa.m4 | 10 +++++++++-
- 1 file changed, 9 insertions(+), 1 deletion(-)
-
-diff --git a/m4/ltp-numa.m4 b/m4/ltp-numa.m4
-index fc3383e..44cb559 100644
---- a/m4/ltp-numa.m4
-+++ b/m4/ltp-numa.m4
-@@ -24,7 +24,13 @@ dnl LTP_CHECK_SYSCALL_NUMA
- dnl ----------------------------
- dnl
- AC_DEFUN([LTP_CHECK_SYSCALL_NUMA], [
-- AC_CHECK_LIB(numa, numa_available, [have_libnuma=yes])
-+ AC_MSG_CHECKING([for numa])
-+ AC_ARG_WITH(
-+ [numa],
-+ AC_HELP_STRING([--without-numa],
-+ [without numa support]),
-+ [],
-+ [AC_CHECK_LIB(numa, numa_available, [have_libnuma=yes])
- AC_CHECK_HEADERS([numa.h numaif.h], [], [have_numa_headers=no])
-
- if test "x$have_numa_headers" != "xno"; then
-@@ -42,3 +48,5 @@ exit(1);
- AC_DEFINE(HAVE_NUMA_V2, 1, [Define to 1 if you have libnuma and it's headers version >= 2 installed.])
- fi
- ])
-+AC_MSG_RESULT([$with_numa])
-+])
---
-2.7.0
-
diff --git a/meta/recipes-extended/ltp/ltp_20180118.bb b/meta/recipes-extended/ltp/ltp_20180118.bb
index d918712c7c..028a957e37 100644
--- a/meta/recipes-extended/ltp/ltp_20180118.bb
+++ b/meta/recipes-extended/ltp/ltp_20180118.bb
@@ -24,7 +24,8 @@ CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
SRCREV = "731cd34e682d297b207668be8b1d15320a9ac1b1"
SRC_URI = "git://github.com/linux-test-project/ltp.git \
- file://0002-Add-knob-to-control-whether-numa-support-should-be-c.patch \
+ file://0001-configure-add-knob-to-control-numa-support.patch \
+ file://0001-configure-Fix-default-value-of-without-numa-switch-i.patch \
file://0003-Add-knob-to-control-tirpc-support.patch \
file://0004-build-Add-option-to-select-libc-implementation.patch \
file://0005-kernel-controllers-Link-with-libfts-explicitly-on-mu.patch \