aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2017-09-06 18:22:46 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-11 17:30:12 +0100
commit024caf6b0848118799fb15b912db7c5e1fc65488 (patch)
tree3a5a6e386bfab470534cdef503650a1ca5762339
parent1f8dae4ca60db21e8c24bf5bcf2153ebd26773f5 (diff)
downloadopenembedded-core-contrib-024caf6b0848118799fb15b912db7c5e1fc65488.tar.gz
bootchart2: update python interpreter
For bootchart2-native, the python interpreter "#!FIXMESTAGINGDIRHOST/usr/bin/python3" of file pybootchartgui is not right. Use '#!${USRBINPATH}/env python3' instead to fix the issue. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb b/meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb
index 4f01734bb0..a3101351ee 100644
--- a/meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb
+++ b/meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb
@@ -134,7 +134,7 @@ do_install () {
echo 'EXIT_PROC="$EXIT_PROC matchbox-window-manager"' >> ${D}${sysconfdir}/bootchartd.conf
# Use python 3 instead of python 2
- sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/pybootchartgui
+ sed -i -e '1s,#!.*python.*,#!${USRBINPATH}/env python3,' ${D}${bindir}/pybootchartgui
}
PACKAGES =+ "pybootchartgui"