aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2016-08-31 15:15:55 +1200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2016-09-06 21:58:58 +1200
commit689ea0d29e7e80880dfd6c8d1b89f1f0b3ac8a80 (patch)
tree1af3c276e9c0213e937abd4bf438a19dc1e7e9e3
parent7c15d9828801d9345c93c0ba40adeb2341471f01 (diff)
downloadopenembedded-core-contrib-689ea0d29e7e80880dfd6c8d1b89f1f0b3ac8a80.tar.gz
recipetool: create: AX_PKG_SWIG should add dependency on swig-native
If AX_PKG_SWIG is found in configure.ac, then what's being looked for is the swig binary, not swig for the target - so fix the dependency accordingly. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
-rw-r--r--scripts/lib/recipetool/create_buildsys.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/lib/recipetool/create_buildsys.py b/scripts/lib/recipetool/create_buildsys.py
index f784f9468a..0ad748ef02 100644
--- a/scripts/lib/recipetool/create_buildsys.py
+++ b/scripts/lib/recipetool/create_buildsys.py
@@ -570,7 +570,7 @@ class AutotoolsRecipeHandler(RecipeHandler):
elif keyword == 'AX_LIB_TAGLIB':
deps.append('taglib')
elif keyword == 'AX_PKG_SWIG':
- deps.append('swig')
+ deps.append('swig-native')
elif keyword == 'AX_PROG_XSLTPROC':
deps.append('libxslt-native')
elif keyword == 'AX_WITH_CURSES':