aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChang Rebecca Swee Fun <rebecca.swee.fun.chang@intel.com>2017-05-09 14:54:51 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-18 14:01:41 +0100
commit720a7230b92d734106d5340a426270dd4e921e8e (patch)
tree28a4d082026c5e4b4d1d0bb63cae548104402f53
parent1a8438601db2e7fd367b6927f6fa4e03cb74854a (diff)
downloadopenembedded-core-contrib-720a7230b92d734106d5340a426270dd4e921e8e.tar.gz
ghostscript: check for incompatible host
The following warning occurs when building with meta-zephyr with MACHINE set to arduino-101-sss: WARNING: /srv/sdc/builds/11319/meta/recipes-extended/ghostscript/ghostscript_9.20.bb: Unable to get checksum for ghostscript SRC_URI entry objarch.h: file could not be found This is due to the the TARGET_ARCH = "arc" for meta-zephyr is not supported by ghostscript and causing bitbake unable to locate the correct config file during recipe parse. Adding checker in the recipe to raise an exception if the target architecture is "arc". This would then only display an error if someone specifically tries to build the recipe: ERROR: ghostscript was skipped: incompatible with host arc-yocto-elf (not in COMPATIBLE_HOST) [YOCTO #11344] Signed-off-by: Chang Rebecca Swee Fun <rebecca.swee.fun.chang@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript_9.20.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.20.bb b/meta/recipes-extended/ghostscript/ghostscript_9.20.bb
index 87a7a5539d..30591c9d76 100644
--- a/meta/recipes-extended/ghostscript/ghostscript_9.20.bb
+++ b/meta/recipes-extended/ghostscript/ghostscript_9.20.bb
@@ -110,3 +110,6 @@ do_install_class-native () {
}
BBCLASSEXTEND = "native"
+
+# ghostscript does not supports "arc"
+COMPATIBLE_HOST = "^(?!arc).*"