aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2017-05-09 15:31:54 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-18 14:01:41 +0100
commit1a3247d38939392bfdcb3eff1da7a1e08eff35f9 (patch)
tree97f821f67082bbe83feda4e66cfbe441ef00e781
parent720a7230b92d734106d5340a426270dd4e921e8e (diff)
downloadopenembedded-core-contrib-1a3247d38939392bfdcb3eff1da7a1e08eff35f9.tar.gz
python3-nose: rename ${bindir}/nosetests into ${bindir}/nosetests3
This resolves a conflict when both python-nose and python3-nose are pulled into an image and try to install ${bindir}/nosetests binary. This matches with how other distros are solving this problem, e.g. Debian: https://packages.debian.org/jessie/all/python3-nose/filelist Also, other packages like python3-setuptools are already doing the same with their binaries. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python3-nose_1.3.7.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-nose_1.3.7.bb b/meta/recipes-devtools/python/python3-nose_1.3.7.bb
index 99bba4403f..1e2ff74f57 100644
--- a/meta/recipes-devtools/python/python3-nose_1.3.7.bb
+++ b/meta/recipes-devtools/python/python3-nose_1.3.7.bb
@@ -17,6 +17,10 @@ S = "${WORKDIR}/nose-${PV}"
inherit setuptools3
+do_install_append() {
+ mv ${D}${bindir}/nosetests ${D}${bindir}/nosetests3
+}
+
RDEPENDS_${PN}_class-target = "\
python3-unittest \
"